summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2020-10-15 15:15:10 -0700
committerShane Stone2020-10-15 15:15:10 -0700
commit1bddd2feff563c07bb85300f77c93b5e0d45b09f (patch)
tree5e59dc27632ceedc481530eff58a5e0b30c4451a
downloadaur-neovim-targets-opt-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f708b0606df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-targets-opt-git
+ pkgdesc = A (neo)vim plugin that adds various text objects to give you more targets to operate on.
+ pkgver = 689.8d6ff29
+ pkgrel = 1
+ url = https://github.com/wellle/targets.vim
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = neovim
+ source = targets::git+https://github.com/wellle/targets.vim.git
+ sha256sums = SKIP
+
+pkgname = neovim-targets-opt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8ed3ec9996
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=neovim-targets-opt-git
+_pkgname=targets
+pkgver=689.8d6ff29
+pkgrel=1
+pkgdesc='A (neo)vim plugin that adds various text objects to give you more targets to operate on.'
+arch=('any')
+url="https://github.com/wellle/${_pkgname}.vim"
+license=('MIT')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" autoload doc plugin
+
+}