summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHelloImWar2023-01-24 23:43:44 -0500
committerHelloImWar2023-01-24 23:43:44 -0500
commit15e58ad2892ada1b0bcc5070f95957ba26e4b18f (patch)
treeb15cfcc3eb060729175f405f70a6213f9512985e
downloadaur-neovim-ufo-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97baf56e6273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = neovim-ufo-git
+ pkgdesc = Not UFO in the sky, but an ultra fold in Neovim.
+ pkgver = 1.3.0.r5.ge3cc802
+ pkgrel = 1
+ url = https://github.com/kevinhwang91/nvim-ufo
+ arch = any
+ groups = neovim-plugins
+ license = BSD
+ makedepends = git
+ depends = neovim
+ depends = neovim-promise-async
+ optdepends = neovim-coc: LSP-based folding support
+ optdepends = neovim-lspconfig: LSP-based folding support
+ optdepends = neovim-tree-sitter: treesitter-based folding support
+ provides = neovim-ufo
+ conflicts = neovim-ufo
+ source = neovim-ufo-git::git+https://github.com/kevinhwang91/nvim-ufo.git
+ sha256sums = SKIP
+
+pkgname = neovim-ufo-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cbb295818fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: HelloImWar <helloimwar at proton dot me>
+
+pkgname=neovim-ufo-git
+_pkgname="${pkgname%-git}"
+pkgver=1.3.0.r5.ge3cc802
+pkgrel=1
+pkgdesc="Not UFO in the sky, but an ultra fold in Neovim."
+arch=('any')
+url="https://github.com/kevinhwang91/nvim-ufo"
+license=('BSD')
+groups=('neovim-plugins')
+depends=('neovim' 'neovim-promise-async')
+optdepends=('neovim-coc: LSP-based folding support'
+ 'neovim-lspconfig: LSP-based folding support'
+ 'neovim-tree-sitter: treesitter-based folding support')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ find lua doc coc-extension \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/plugins/start/$pkgname/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}