summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2023-01-23 11:39:59 +0100
committerD3SOX2023-01-23 11:39:59 +0100
commit3839a6ecf232f224b681dd6603cd050e2ef1fcbf (patch)
treee5a23f56a36015b65c9d348d1d998fd1ef4ce728
parent1d83cf5cf28218f005522b646357e66a5a2210e3 (diff)
downloadaur-3839a6ecf232f224b681dd6603cd050e2ef1fcbf.tar.gz
update to nerd-fonts 2.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--allow-glyphdir.diff21
3 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d6683367ac7..1b7d14c5f765 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-sf-mono
pkgdesc = Monospaced variant of San Francisco. Sourced directly from Apple, patched with the Nerd Fonts Patcher
- pkgver = 2.1.0
- pkgrel = 10
+ pkgver = 2.3.1
+ pkgrel = 1
url = https://developer.apple.com/fonts/
arch = any
license = custom
@@ -13,13 +13,11 @@ pkgbase = nerd-fonts-sf-mono
makedepends = parallel
provides = nerd-fonts-sf-mono
conflicts = nerd-fonts-sf-mono
- source = SF-Mono-11.dmg::https://developer.apple.com/design/downloads/SF-Mono.dmg
- source = font-patcher-2.1.0::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.1.0/font-patcher
- source = allow-glyphdir.diff
- source = svn+https://github.com/ryanoasis/nerd-fonts/tags/v2.1.0/src/glyphs
+ source = SF-Mono-10.dmg::https://developer.apple.com/design/downloads/SF-Mono.dmg
+ source = font-patcher-2.3.1::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.3.1/font-patcher
+ source = svn+https://github.com/ryanoasis/nerd-fonts/tags/v2.3.1/src/glyphs
sha256sums = abaf6d62cd5b17ae1837ab40a35386733a3f603cf641a84cf59b1d7fb4caac39
- sha256sums = 3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859
- sha256sums = 6fad8dead6215b1d8cedbbce3d1bc1fc7c1b0bb06ea70518334bd443a7ba543f
+ sha256sums = a6f2c45d84b29fcb13575d9fe778545ba3b0200efc0e5fb66ce679108f43f397
sha256sums = SKIP
pkgname = nerd-fonts-sf-mono
diff --git a/PKGBUILD b/PKGBUILD
index a16a29f6e6a5..9b0b38de5541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=nerd-fonts-sf-mono
-pkgver=2.1.0
-pkgrel=10
-_fontver=11
+pkgver=2.3.1
+pkgrel=1
+_fontver=10
pkgdesc="Monospaced variant of San Francisco. Sourced directly from Apple, patched with the Nerd Fonts Patcher"
arch=('any')
url='https://developer.apple.com/fonts/'
@@ -10,16 +10,13 @@ license=('custom')
makedepends=('git' 'p7zip' 'python' 'fontforge' 'subversion' 'parallel')
conflicts=('nerd-fonts-sf-mono')
provides=('nerd-fonts-sf-mono')
-source=("SF-Mono-$_fontver.dmg::https://developer.apple.com/design/downloads/SF-Mono.dmg" "font-patcher-$pkgver::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$pkgver/font-patcher" "allow-glyphdir.diff" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$pkgver/src/glyphs")
+source=("SF-Mono-$_fontver.dmg::https://developer.apple.com/design/downloads/SF-Mono.dmg" "font-patcher-$pkgver::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$pkgver/font-patcher" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$pkgver/src/glyphs")
sha256sums=('abaf6d62cd5b17ae1837ab40a35386733a3f603cf641a84cf59b1d7fb4caac39'
- '3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859'
- '6fad8dead6215b1d8cedbbce3d1bc1fc7c1b0bb06ea70518334bd443a7ba543f'
+ 'a6f2c45d84b29fcb13575d9fe778545ba3b0200efc0e5fb66ce679108f43f397'
'SKIP')
build() {
- _patcher="font-patcher-$pkgver-glyphdir"
- # apply patch to font-patcher to allow using custom glyph directory
- patch -p1 --follow-symlinks -o "$_patcher" < allow-glyphdir.diff
+ _patcher="font-patcher-$pkgver"
# remove previous files
rm -rf SFMonoFonts
# extract dmg
diff --git a/allow-glyphdir.diff b/allow-glyphdir.diff
deleted file mode 100644
index 2934c4532c51..000000000000
--- a/allow-glyphdir.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/font-patcher-2.1.0 b/font-patcher-2.1.0
-index 815d1fd48..55169be26 100755
---- a/font-patcher-2.1.0
-+++ b/font-patcher-2.1.0
-@@ -85,7 +85,7 @@ class font_patcher:
- if symfont:
- symfont.close()
- symfont = None
-- symfont = fontforge.open(__dir__ + "/src/glyphs/" + patch['Filename'])
-+ symfont = fontforge.open(self.args.glyphdir + patch['Filename'])
-
- # Match the symbol font size to the source font size
- symfont.em = self.sourceFont.em
-@@ -143,6 +143,7 @@ class font_patcher:
- parser.add_argument('--custom', dest='custom', default=False, type=str, nargs='?', help='Specify a custom symbol font. All new glyphs will be copied, with no scaling applied.')
- parser.add_argument('-ext', '--extension', dest='extension', default="", type=str, nargs='?', help='Change font file type to create (e.g., ttf, otf)')
- parser.add_argument('-out', '--outputdir', dest='outputdir', default=".", type=str, nargs='?', help='The directory to output the patched font file to')
-+ parser.add_argument('--glyphdir', dest='glyphdir', default=__dir__ + "/src/glyphs/", type=str, nargs='?', help='Path to glyphs to be used for patching')
-
- # progress bar arguments - https://stackoverflow.com/questions/15008758/parsing-boolean-values-with-argparse
- progressbars_group_parser = parser.add_mutually_exclusive_group(required=False)