summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Yantarev2023-08-31 18:23:32 +0000
committerDenis Yantarev2023-08-31 18:23:32 +0000
commit9ece18371a5cc81e18e8b6b315f64785c2d13975 (patch)
tree2273429da16617870e7c15fc7c2ac2c34f912f84
parent47405543672512fea584ebb321a2effb2a995412 (diff)
downloadaur-9ece18371a5cc81e18e8b6b315f64785c2d13975.tar.gz
Updated to 3.1.15
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD71
-rw-r--r--ad_open.patch84
-rw-r--r--netatalk.install21
-rw-r--r--python3.patch11
5 files changed, 48 insertions, 158 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63b5015b5ea0..63610805147d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = netatalk
pkgdesc = Open-source implementation of the Apple Filing Protocol
- pkgver = 3.1.13
- pkgrel = 3
+ pkgver = 3.1.15
+ pkgrel = 1
url = https://netatalk.sourceforge.io
- install = netatalk.install
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL
+ license = GPL2
depends = acl
depends = avahi>=0.6
depends = cracklib
@@ -20,15 +19,11 @@ pkgbase = netatalk
depends = perl
depends = python
depends = tdb>=1.4.5
- replaces = netatalk-git
- replaces = netatalk2
+ conflicts = netatalk-git
+ conflicts = netatalk2
backup = etc/afp.conf
backup = etc/extmap.conf
- source = http://downloads.sourceforge.net/project/netatalk/netatalk/3.1.13/netatalk-3.1.13.tar.bz2
- source = ad_open.patch
- source = python3.patch
- md5sums = 697421623c32ee0ab9c8076191766e5f
- md5sums = 69525b38032baefbaa705f68f93c1d31
- md5sums = 8a81f88e01bcb4225e39e667b01dc1c6
+ source = https://github.com/Netatalk/netatalk/releases/download/netatalk-3-1-15/netatalk-3.1.15.tar.bz2
+ md5sums = ae542961a541ee786c8ac33daba2e00f
pkgname = netatalk
diff --git a/PKGBUILD b/PKGBUILD
index b56eeb72ca03..c05060ee3364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,45 +5,56 @@
# Contributor: Farhan Yousaf <farhany at xaviya dot com>
pkgname=netatalk
-pkgver=3.1.13
-pkgrel=3
+pkgver=3.1.15
+pkgrel=1
pkgdesc='Open-source implementation of the Apple Filing Protocol'
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://netatalk.sourceforge.io'
-license=('GPL')
-depends=('acl' 'avahi>=0.6' 'cracklib' 'dbus-glib' 'dbus-python'
- 'libevent' 'mariadb-libs' 'perl' 'python' 'tdb>=1.4.5')
-replaces=('netatalk-git' 'netatalk2')
+license=('GPL2')
+
+source=(https://github.com/Netatalk/${pkgname}/releases/download/${pkgname}-${pkgver//./-}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('ae542961a541ee786c8ac33daba2e00f')
+
+arch=('i686'
+ 'x86_64'
+ 'armv6h'
+ 'armv7h'
+ 'aarch64')
+
+depends=('acl'
+ 'avahi>=0.6'
+ 'cracklib'
+ 'dbus-glib'
+ 'dbus-python'
+ 'libevent'
+ 'mariadb-libs'
+ 'perl'
+ 'python'
+ 'tdb>=1.4.5')
+
+conflicts=('netatalk-git'
+ 'netatalk2')
+
backup=('etc/afp.conf'
'etc/extmap.conf')
-install=$pkgname.install
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
- ad_open.patch
- python3.patch)
-md5sums=('697421623c32ee0ab9c8076191766e5f'
- '69525b38032baefbaa705f68f93c1d31'
- '8a81f88e01bcb4225e39e667b01dc1c6')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p0 < "$srcdir/ad_open.patch"
- patch -p0 < "$srcdir/python3.patch"
-}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- autoreconf -fi
- CFLAGS="-Wno-unused-result -O2" \
- ./configure \
- --prefix=/usr --localstatedir=/var/state --sbindir=/usr/bin --sysconfdir=/etc \
- --enable-silent-rules --enable-pgp-uam \
- --with-init-style=systemd --with-cracklib --with-cnid-cdb-backend \
- --without-libevent --without-tdb
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state \
+ --enable-silent-rules \
+ --enable-pgp-uam \
+ --with-init-style=systemd \
+ --with-cracklib \
+ --with-cnid-cdb-backend \
+ --without-tdb
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/ad_open.patch b/ad_open.patch
deleted file mode 100644
index 9a704469a6de..000000000000
--- a/ad_open.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- libatalk/adouble/ad_open.c.orig 2022-03-22 04:44:25 UTC
-+++ libatalk/adouble/ad_open.c
-@@ -1574,6 +1574,8 @@ static bool ad_entry_check_size(uint32_t eid,
- uint32_t required_len;
-
- if (eid >= ADEID_MAX) {
-+ LOG(log_error, logtype_ad, "ad_entry_check_size %d is greater than %d",
-+ eid, ADEID_MAX);
- return false;
- }
- if (got_len == 0) {
-@@ -1585,6 +1587,7 @@ static bool ad_entry_check_size(uint32_t eid,
- * Shouldn't happen: implicitly initialized to zero because
- * explicit initializer missing.
- */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size explicit initializer missing");
- return false;
- }
- if (ad_checks[eid].expected_len == -1) {
-@@ -1594,6 +1597,8 @@ static bool ad_entry_check_size(uint32_t eid,
- if (ad_checks[eid].fixed_size) {
- if (ad_checks[eid].expected_len != got_len) {
- /* Wrong size fo fixed size entry. */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size wrong size to fixed size entry (%d != %d)",
-+ ad_checks[eid].expected_len, got_len);
- return false;
- }
- required_len = got_len;
-@@ -1604,12 +1609,16 @@ static bool ad_entry_check_size(uint32_t eid,
- * Too small for variable sized entry with
- * minimum size.
- */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size too small for variable sized entry (%d < %d)",
-+ got_len, ad_checks[eid].expected_len);
- return false;
- }
- required_len = got_len;
- } else {
- if (got_len > ad_checks[eid].expected_len) {
- /* Too big for variable sized entry. */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size too big for variable sized entry (%d > %d)",
-+ got_len, ad_checks[eid].expected_len);
- return false;
- }
- /*
-@@ -1621,10 +1630,14 @@ static bool ad_entry_check_size(uint32_t eid,
- }
- if (off + required_len < off) {
- /* wrap around */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size wrap around (%d + %d < %d)",
-+ off, required_len, off);
- return false;
- }
- if (off + required_len > bufsize) {
- /* overflow */
-+ LOG(log_error, logtype_ad, "ad_entry_check_size overflow (%d + %d > %d)",
-+ off, required_len, bufsize);
- return false;
- }
- return true;
-@@ -1637,14 +1650,21 @@ void *ad_entry(const struct adouble *ad, int eid)
- size_t len = ad_getentrylen(ad, eid);
- bool valid;
-
-+ if (bufsize == 0) {
-+ bufsize = sizeof(ad->ad_data) - (off + len);
-+ }
-+
- valid = ad_entry_check_size(eid, bufsize, off, len);
- if (!valid) {
-+ LOG(log_error, logtype_ad, "ad_entry: not valid");
- return NULL;
- }
-
-- if (off == 0 || len == 0) {
-+ /*if (off == 0 || len == 0) {
-+ LOG(log_error, logtype_ad, "ad_entry: off or len is 0 (off: %d, len: %d)",
-+ off, len);
- return NULL;
-- }
-+ }*/
-
- return ((struct adouble *)ad)->ad_data + off;
- }
diff --git a/netatalk.install b/netatalk.install
deleted file mode 100644
index b27dcd44b3d5..000000000000
--- a/netatalk.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_install() {
- post_upgrade
-}
-post_upgrade() {
- if [ -f /etc/rc.conf ];then
- if [ "`grep -E '(cnid|atalkd|afpd)' /etc/rc.conf`" ];then
- echo '>>> Detected old netatalk daemon entries in';
- echo '>>> /etc/rc.conf, please replace these with';
- echo '>>> "netatalk" before restarting!';
- else echo '>>> Add "netatalk" to your DAEMONS list';fi
- fi
- if [ -f /etc/avahi/services/adisk.service ] ||
- [ -f /etc/avahi/services/afpd.service ];then
- echo '>>> Detected old netatalk service files in';
- echo '>>> /etc/avahi/services, please delete these';
- echo '>>> before restarting!';fi
- if [ -f /opt/netatalk/afp_signature.conf ] ||
- [ -f /opt/netatalk/afp_voluuid.conf ]; then
- echo '>>> Found *.conf in /opt/netatalk, please';
- echo '>>> migrate these to /var/state/netatalk before restarting';fi
-}
diff --git a/python3.patch b/python3.patch
deleted file mode 100644
index 822a7b41bd9c..000000000000
--- a/python3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/shell_utils/afpstats 2021-04-13 11:27:32.741525447 +0300
-+++ contrib/shell_utils/afpstats.orig 2021-04-13 11:27:13.292504042 +0300
-@@ -23,7 +23,7 @@
-
- reply = iface.GetUsers()
- for name in reply:
-- print name
-+ print(name)
-
- if __name__ == '__main__':
- main()