summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Yantarev2019-08-13 02:33:01 +0300
committerDenis Yantarev2019-08-13 02:33:01 +0300
commitb5a7ce8bd1237df9bf97b81450fa09d170ea2979 (patch)
tree19f16b6ced6af86889066c2f82309ec858c80e88
parent80557820da564ecc3e8fd1846f19efc41d416d9d (diff)
downloadaur-b5a7ce8bd1237df9bf97b81450fa09d170ea2979.tar.gz
Switched to system tdb
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 861f84711896..95535be31199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netatalk
pkgdesc = Open-source implementation of the Apple Filing Protocol
pkgver = 3.1.12
- pkgrel = 1
+ pkgrel = 2
url = http://netatalk.sourceforge.net
install = netatalk.install
arch = i686
@@ -10,13 +10,14 @@ pkgbase = netatalk
arch = armv7h
license = GPL
depends = avahi>=0.6
- depends = libldap
- depends = libgcrypt>=1.2.3
+ depends = dbus-glib
depends = libevent
+ depends = libgcrypt>=1.2.3
+ depends = libldap
+ depends = pam
depends = python2
- depends = dbus-glib
depends = python2-dbus
- depends = pam
+ depends = tdb
replaces = netatalk-git
replaces = netatalk2
backup = etc/afp.conf
diff --git a/PKGBUILD b/PKGBUILD
index 5fbc64853413..40471f364602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=netatalk
pkgver=3.1.12
-pkgrel=1
+pkgrel=2
pkgdesc='Open-source implementation of the Apple Filing Protocol'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='http://netatalk.sourceforge.net'
license=('GPL')
-depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent' 'python2' 'dbus-glib' 'python2-dbus' 'pam')
+depends=('avahi>=0.6' 'dbus-glib' 'libevent' 'libgcrypt>=1.2.3' 'libldap' 'pam' 'python2' 'python2-dbus' 'tdb')
replaces=('netatalk-git' 'netatalk2')
backup=('etc/afp.conf'
'etc/extmap.conf')
@@ -30,9 +30,11 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
autoreconf -fi
CFLAGS="-Wno-unused-result -O2" \
- ./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc \
- --sbindir=/usr/bin --enable-silent-rules --with-init-style=systemd \
- --with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
+ ./configure \
+ --prefix=/usr --localstatedir=/var/state --sbindir=/usr/bin --sysconfdir=/etc \
+ --enable-silent-rules --enable-pgp-uam \
+ --with-init-style=systemd --with-cracklib --with-cnid-cdb-backend \
+ --without-libevent --without-tdb
make
}