summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Yantarev2015-06-09 00:44:30 +0300
committerDenis Yantarev2015-06-09 00:44:30 +0300
commitee0ca9e00dc164b089ed1edd687ddae5ca504e6e (patch)
treed90c9d5264500821021de51dbda44886ac31a8f2
downloadaur-ee0ca9e00dc164b089ed1edd687ddae5ca504e6e.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD45
-rw-r--r--avahi-client.patch54
-rw-r--r--netatalk.install21
-rw-r--r--python2.patch8
5 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5ad3376d6a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = netatalk
+ pkgdesc = Open-source implementation of the Apple Filing Protocol
+ pkgver = 3.1.7
+ pkgrel = 1
+ url = http://netatalk.sourceforge.net
+ install = netatalk.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = avahi>=0.6
+ depends = libldap
+ depends = libgcrypt>=1.2.3
+ depends = libevent
+ depends = python2
+ depends = dbus-glib
+ depends = python2-dbus
+ replaces = netatalk-git
+ replaces = netatalk2
+ backup = etc/afp.conf
+ backup = etc/extmap.conf
+ source = http://downloads.sourceforge.net/project/netatalk/netatalk/3.1.7/netatalk-3.1.7.tar.bz2
+ source = avahi-client.patch
+ source = python2.patch
+ md5sums = 831ec8bf9e084b64f965d16c528af299
+ md5sums = 00379aacb88dcac8c1e0513da1a5f24c
+ md5sums = 97bc0467dd8a866d9f0835d6440e3c19
+
+pkgname = netatalk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dc6284b36e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Denis Yantarev <denis dot yantarev at gmail dot com>
+# Contributor: SJ_UnderWater
+# Contributor: Dominik Dingel <mail at wodar dot de>
+# Contributor: William Udovich <nerdzrule7 at earthlink dot net>
+# Contributor: Farhan Yousaf <farhany at xaviya dot com>
+
+pkgname=netatalk
+pkgver=3.1.7
+pkgrel=1
+pkgdesc='Open-source implementation of the Apple Filing Protocol'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='http://netatalk.sourceforge.net'
+license=('GPL')
+depends=('avahi>=0.6' 'libldap' 'libgcrypt>=1.2.3' 'libevent' 'python2' 'dbus-glib' 'python2-dbus')
+replaces=('netatalk-git' 'netatalk2')
+backup=('etc/afp.conf'
+ 'etc/extmap.conf')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
+ avahi-client.patch
+ python2.patch)
+md5sums=('831ec8bf9e084b64f965d16c528af299'
+ '00379aacb88dcac8c1e0513da1a5f24c'
+ '97bc0467dd8a866d9f0835d6440e3c19')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 < "$srcdir/python2.patch"
+ patch -p0 < "$srcdir/avahi-client.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ autoreconf -fi
+ CFLAGS="-Wno-unused-result -O2" \
+ ./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc \
+ --sbindir=/usr/bin --enable-silent-rules --with-init-style=systemd \
+ --with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --with-libevent=no
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/avahi-client.patch b/avahi-client.patch
new file mode 100644
index 000000000000..a1eef2b33d66
--- /dev/null
+++ b/avahi-client.patch
@@ -0,0 +1,54 @@
+--- macros/zeroconf.m4.orig 2014-06-08 21:23:46.000000000 +0400
++++ macros/zeroconf.m4 2014-06-08 21:36:25.000000000 +0400
+@@ -25,23 +25,7 @@
+ zeroconf_dir="$zeroconf"
+ fi
+
+- # mDNS support using mDNSResponder
+- AC_CHECK_HEADER(
+- dns_sd.h,
+- AC_CHECK_LIB(
+- dns_sd,
+- DNSServiceRegister,
+- AC_DEFINE(USE_ZEROCONF, 1, [Use DNS-SD registration]))
+- )
+-
+- if test "$ac_cv_lib_dns_sd_DNSServiceRegister" = yes; then
+- ZEROCONF_LIBS="-ldns_sd"
+- AC_DEFINE(HAVE_MDNS, 1, [Use mDNSRespnder/DNS-SD registration])
+- found_zeroconf=yes
+- fi
+-
+ # mDNS support using Avahi
+- if test x"$found_zeroconf" != x"yes" ; then
+ AC_CHECK_HEADER(
+ avahi-client/client.h,
+ AC_CHECK_LIB(
+@@ -62,10 +46,26 @@
+ found_zeroconf=yes
+ ;;
+ esac
++
++ # mDNS support using mDNSResponder
++ if test x"$found_zeroconf" != x"yes" ; then
++ AC_CHECK_HEADER(
++ dns_sd.h,
++ AC_CHECK_LIB(
++ dns_sd,
++ DNSServiceRegister,
++ AC_DEFINE(USE_ZEROCONF, 1, [Use DNS-SD registration]))
++ )
++
++ if test "$ac_cv_lib_dns_sd_DNSServiceRegister" = yes; then
++ ZEROCONF_LIBS="-ldns_sd"
++ AC_DEFINE(HAVE_MDNS, 1, [Use mDNSRespnder/DNS-SD registration])
++ found_zeroconf=yes
++ fi
++ fi
+ CPPFLAGS="$savedcppflags"
+ LDFLAGS="$savedldflags"
+ fi
+- fi
+
+ netatalk_cv_zeroconf=no
+ AC_MSG_CHECKING([whether to enable Zerconf support])
diff --git a/netatalk.install b/netatalk.install
new file mode 100644
index 000000000000..b27dcd44b3d5
--- /dev/null
+++ b/netatalk.install
@@ -0,0 +1,21 @@
+post_install() {
+ post_upgrade
+}
+post_upgrade() {
+ if [ -f /etc/rc.conf ];then
+ if [ "`grep -E '(cnid|atalkd|afpd)' /etc/rc.conf`" ];then
+ echo '>>> Detected old netatalk daemon entries in';
+ echo '>>> /etc/rc.conf, please replace these with';
+ echo '>>> "netatalk" before restarting!';
+ else echo '>>> Add "netatalk" to your DAEMONS list';fi
+ fi
+ if [ -f /etc/avahi/services/adisk.service ] ||
+ [ -f /etc/avahi/services/afpd.service ];then
+ echo '>>> Detected old netatalk service files in';
+ echo '>>> /etc/avahi/services, please delete these';
+ echo '>>> before restarting!';fi
+ if [ -f /opt/netatalk/afp_signature.conf ] ||
+ [ -f /opt/netatalk/afp_voluuid.conf ]; then
+ echo '>>> Found *.conf in /opt/netatalk, please';
+ echo '>>> migrate these to /var/state/netatalk before restarting';fi
+}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..eaf02c71c891
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,8 @@
+--- contrib/shell_utils/afpstats.orig 2014-03-04 09:56:31.000000000 +0400
++++ contrib/shell_utils/afpstats 2014-03-04 09:57:23.000000000 +0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ usage = """Usage:
+ python afpstats.py