summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-03-18 17:15:25 -0400
committerPatrick Northon2021-03-18 17:15:25 -0400
commit829e1e9a18a4d6838c07235b78ec5dc30d38e277 (patch)
tree418fe54ae36be881b3d7a4893e92ac94e612ce1d
downloadaur-829e1e9a18a4d6838c07235b78ec5dc30d38e277.tar.gz
initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea8fce038f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = netns-helper-git
+ pkgdesc = Helper systemd services to create network namespaces for other programs and services.
+ pkgver = r11.5bd5db7
+ pkgrel = 1
+ url = https://gitlab.com/patlefort/netns-helper
+ arch = any
+ license = GPL3
+ depends = systemd
+ depends = iproute2
+ provides = netns-helper
+ source = git+https://gitlab.com/patlefort/netns-helper
+ sha256sums = SKIP
+
+pkgname = netns-helper-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13263ac7c275
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+_pkgname=netns-helper
+pkgname=netns-helper-git
+provides=("${_pkgname}")
+pkgver=r11.5bd5db7
+pkgrel=1
+pkgdesc="Helper systemd services to create network namespaces for other programs and services."
+url="https://gitlab.com/patlefort/${_pkgname}"
+license=("GPL3")
+depends=("systemd" "iproute2")
+arch=("any")
+optdepends=()
+sha256sums=("SKIP")
+source=("git+https://gitlab.com/patlefort/${_pkgname}")
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -dm755 "${pkgdir}/etc/netns-helper/ns"
+ install -dm755 "${pkgdir}/usr/lib/systemd/system"
+ install -Dm644 "systemd/system"/* -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm755 "scripts"/* -t "${pkgdir}/usr/bin"
+ install -Dm644 "license.txt" -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}