summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292019-06-02 11:11:08 +0200
committerSpike292019-06-02 11:11:08 +0200
commit2c1e30304fde68ca3d24812fec1e3bcafc2dbc46 (patch)
tree88540f6a01cd61895c2e2ae8dfa9cd3e72acea65
parent5c17128cbba84c82ec156c3de7c7ac1e563e4fa6 (diff)
downloadaur-2c1e30304fde68ca3d24812fec1e3bcafc2dbc46.tar.gz
New git commit, improve the PKGBUILD and fix the installation of gamepacks due to a recent upstream change
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ea9ac1c6708..f4487ee98665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netradiant-git
pkgdesc = The open source, cross platform level editor for idtech games (GTKRadiant fork) - git version
- pkgver = r1793.5c0f69d0
- pkgrel = 2
+ pkgver = r1838.92e4e444
+ pkgrel = 1
epoch = 1
url = https://gitlab.com/xonotic/netradiant
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c6b48794f596..cf21228686dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r1793.5c0f69d0
-pkgrel=2
+pkgver=r1838.92e4e444
+pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GTKRadiant fork) - git version'
url='https://gitlab.com/xonotic/netradiant'
@@ -31,19 +31,24 @@ build() {
-DDOWNLOAD_GAMEPACKS=ON \
-DGAMEPACKS_LICENSE_LIST=free \
-DGAMEPACKS_NAME_LIST=none
+
+ cmake --build build -- -j$(nproc)
+ cmake -H. -Bbuild # This step is needed again for CMake to detect the gamepacks it has to install
}
package() {
cd "${srcdir}/${pkgname}/"
- cmake --build build --target install -- -j$(nproc)
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/netradiant/LICENSE"
- rm -r ${pkgdir}/usr/share/mime/ # Map mime type doesn't work and shouldn't be handled this way
+ cmake --build build -- install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/netradiant/LICENSE"
+ rm -r ${pkgdir}/usr/share/mime/ # Map mime type doesn't work and produces a pacman warning
## Fix (some of) the included gamepacks so they work with the official archlinux packages
## Normally we would do this in prepare(), but this is not an viable option, as the Makefile initiates the download and update of the gamepacks.
## So we would need to call the referenced download script ourselves in prepare() and modify the Makefile so it doesn't try to do it in build() too.
## Not worth it.
+ ## Don't forget to comment the lines with the gamepacks that you don't use, otherwise the sed command will fail.
sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/nexuiz/"' "${pkgdir}/usr/share/netradiant/games/nexuiz.game"
sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/warsow/"' "${pkgdir}/usr/share/netradiant/games/warsow.game"