summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292022-06-22 20:04:52 +0200
committerSpike292022-06-22 20:04:52 +0200
commit7130ce0046272bf19e2da767caefe4b2674b0021 (patch)
tree0854b25a9498e17b583ceb873d774533792a0a00
parent603009ca20b9ebda0b51236c0429fc9bcca3ecc3 (diff)
downloadaur-7130ce0046272bf19e2da767caefe4b2674b0021.tar.gz
Move the submodules handling to a prepare() stage
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f62a31e9f16..fde7e0c2ec54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netradiant-git
pkgdesc = The open source, cross platform level editor for idtech games (GtkRadiant fork)
- pkgver = r2241.924b92f6
+ pkgver = r2259.ed990b29
pkgrel = 1
epoch = 1
url = https://netradiant.gitlab.io/
diff --git a/PKGBUILD b/PKGBUILD
index 442dc879923b..488c8a1a8115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r2241.924b92f6
+pkgver=r2259.ed990b29
pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GtkRadiant fork)'
@@ -21,20 +21,23 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${pkgname}/"
+ # Fetch submodules (such as Crunch and Daemonmap, they are compiled when present)
+ git submodule update --init --recursive
+}
+
build() {
cd "${srcdir}/${pkgname}/"
# Workaround for https://gitlab.com/xonotic/netradiant/-/issues/156
export CXXFLAGS+=" -Wp,-U_GLIBCXX_ASSERTIONS"
- # Fetch submodules by default (such as Crunch and Daemonmap, they are compiled if present)
- git submodule update --init --recursive
-
# Possible values for the GAMEPACKS_LICENSE_LIST filter are "free",
# "all" (free + proprietary) and "none".
# For example, to only fetch Xonotic and Unvanquished gamepacks,
# use -DGAMEPACKS_LICENSE_LIST=none with -DGAMEPACKS_NAME_LIST="Xonotic Unvanquished".
- # Please refer to the NetRadiant README for more instructions.
+ # Please refer to the NetRadiant documentation for more instructions.
cmake -G "Unix Makefiles" -S. -Bbuild \
-DCMAKE_BUILD_TYPE=Release \
-DOpenGL_GL_PREFERENCE="GLVND" \