summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292021-04-27 19:06:58 +0200
committerSpike292021-04-27 19:06:58 +0200
commitcc1700445398400ebaee88f22bc3e716a697085b (patch)
treef23aba974abb7f674e4243bcb04637b521872b81
parenta78903d38ddcfb7d79147ab1dd518856e540aa6d (diff)
downloadaur-cc1700445398400ebaee88f22bc3e716a697085b.tar.gz
Fetch submodules by default, they are needed for Unvanquished maps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ae0b6e62a0a..b791823c4aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netradiant-git
pkgdesc = The open source, cross platform level editor for idtech games (GtkRadiant fork)
- pkgver = r2146.c94d5210
- pkgrel = 2
+ pkgver = r2180.93836301
+ pkgrel = 1
epoch = 1
url = https://netradiant.gitlab.io/
arch = i686
@@ -26,6 +26,7 @@ pkgbase = netradiant-git
provides = q2map
provides = qdata3
provides = h2data
+ provides = daemonmap
source = netradiant-git::git+https://gitlab.com/xonotic/netradiant.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9589f5fa56f5..a6e332a13bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r2146.c94d5210
-pkgrel=2
+pkgver=r2180.93836301
+pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GtkRadiant fork)'
url='https://netradiant.gitlab.io/'
@@ -12,7 +12,7 @@ license=('GPL' 'BSD' 'LGPL')
arch=('i686' 'x86_64')
depends=('gtk2' 'gtkglext' 'minizip' 'libjpeg-turbo' 'libwebp')
makedepends=('git' 'svn' 'wget' 'unzip' 'cmake' 'make')
-provides=('netradiant' 'q3map2' 'q3data' 'q2map' 'qdata3' 'h2data')
+provides=('netradiant' 'q3map2' 'q3data' 'q2map' 'qdata3' 'h2data' 'daemonmap')
source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git")
sha256sums=('SKIP')
@@ -24,8 +24,8 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}/"
- # Optional, fetch submodules too (such as Crunch and Daemonmap, they will be compiled if present)
- # git submodule update --init --recursive
+ # Fetch submodules by default (such as Crunch and Daemonmap, they are compiled if present)
+ git submodule update --init --recursive
# Possible values for the GAMEPACKS_LICENSE_LIST filter are "free",
# "all" (free + proprietary) and "none".
@@ -49,6 +49,6 @@ package() {
cmake --install build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # update-mime-database will erase the map mime type anyway
+ # Running update-mime-database will erase the map mime type anyway
rm -r ${pkgdir}/usr/share/mime/
}