summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292024-04-13 12:31:42 +0200
committerSpike292024-04-13 12:31:42 +0200
commite70288925059d51ba8181a70c6a8ec866fe4d287 (patch)
tree7c8a1f852744afe17e0cc43682dad0a32b5b81c7
parent0e3934950745f13b2ae2b9e0633ea2a764dc6814 (diff)
downloadaur-e70288925059d51ba8181a70c6a8ec866fe4d287.tar.gz
Properly handle the Crunch submodule (as described in the Arch wiki) and add its license to the list
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7751f4c450dd..9b52750cbdd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,10 @@ pkgbase = netradiant-git
url = https://netradiant.gitlab.io/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
license = BSD
- license = LGPL
+ license = LGPL2.1
+ license = Zlib
makedepends = cmake
makedepends = git
makedepends = make
@@ -39,6 +40,8 @@ pkgbase = netradiant-git
provides = q3map2
provides = qdata3
source = netradiant-git::git+https://gitlab.com/xonotic/netradiant.git
+ source = git+https://github.com/DaemonEngine/crunch.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = netradiant-git
diff --git a/PKGBUILD b/PKGBUILD
index f014375cadf7..6621b59d4afb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,15 @@ pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GtkRadiant fork)'
url='https://netradiant.gitlab.io/'
-license=('GPL' 'BSD' 'LGPL')
+license=('GPL2' 'BSD' 'LGPL2.1' 'Zlib')
arch=('i686' 'x86_64')
depends=('bash' 'cairo' 'gdk-pixbuf2' 'gcc-libs' 'glibc' 'glib2' 'gtk2' 'gtkglext' 'libglvnd' 'libjpeg-turbo' 'libpng' 'libwebp' 'libxml2' 'libx11' 'minizip' 'pango' 'zlib')
makedepends=('cmake' 'git' 'make' 'svn' 'unzip' 'wget')
provides=('netradiant' 'h2data' 'q2map' 'q3data' 'q3map2' 'qdata3')
-source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git"
+ "git+https://github.com/DaemonEngine/crunch.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${srcdir}/${pkgname}/"
@@ -23,8 +25,11 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
+
# Fetch the Crunch submodule
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.libs/crunch.url "${srcdir}/crunch"
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -39,7 +44,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DOpenGL_GL_PREFERENCE=GLVND \
-DFHS_INSTALL=ON \
- -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
-DDOWNLOAD_GAMEPACKS=ON \
-DGAMEPACKS_LICENSE_LIST=free \
-DGAMEPACKS_NAME_LIST=none
@@ -54,5 +59,5 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Running update-mime-database will erase the map mime type anyway
- rm -r ${pkgdir}/usr/share/mime/
+ rm -r "${pkgdir}/usr/share/mime/"
}