summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292023-02-04 10:43:29 +0100
committerSpike292023-02-04 10:43:29 +0100
commitf7929a7cabe546bb45646a930820686bd526a657 (patch)
tree0da4d94ebef49dad1f4223904be165a650d94455
parent07aaf60f0224a8dae6d84564fc2664df696f91b3 (diff)
downloadaur-f7929a7cabe546bb45646a930820686bd526a657.tar.gz
Remove mentions of daemonmap (no longer provided) and rework some comments
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9032887f5e0b..0f8961e2e381 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netradiant-git
pkgdesc = The open source, cross platform level editor for idtech games (GtkRadiant fork)
- pkgver = r2268.da0e52ba
+ pkgver = r2274.77fe8cf1
pkgrel = 1
epoch = 1
url = https://netradiant.gitlab.io/
@@ -26,7 +26,6 @@ pkgbase = netradiant-git
provides = q2map
provides = qdata3
provides = h2data
- provides = daemonmap
conflicts = netradiant-custom
source = netradiant-git::git+https://gitlab.com/xonotic/netradiant.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 418378534b03..1278daad8e22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r2268.da0e52ba
+pkgver=r2274.77fe8cf1
pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GtkRadiant fork)'
@@ -12,7 +12,7 @@ license=('GPL' 'BSD' 'LGPL')
arch=('i686' 'x86_64')
depends=('gtk2' 'gtkglext' 'minizip' 'libjpeg-turbo' 'libwebp')
makedepends=('git' 'svn' 'wget' 'unzip' 'cmake' 'make')
-provides=('netradiant' 'q3map2' 'q3data' 'q2map' 'qdata3' 'h2data' 'daemonmap')
+provides=('netradiant' 'q3map2' 'q3data' 'q2map' 'qdata3' 'h2data')
conflicts=('netradiant-custom')
source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git")
sha256sums=('SKIP')
@@ -24,7 +24,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}/"
- # Fetch submodules (such as Crunch and Daemonmap, they are compiled when present)
+ # Fetch the Crunch submodule (it is compiled when present)
git submodule update --init --recursive
}
@@ -33,9 +33,9 @@ build() {
# Possible values for the GAMEPACKS_LICENSE_LIST filter are "free",
# "all" (free + proprietary) and "none".
- # For example, to only fetch Xonotic and Unvanquished gamepacks,
- # use -DGAMEPACKS_LICENSE_LIST=none with -DGAMEPACKS_NAME_LIST="Xonotic Unvanquished".
- # Please refer to the NetRadiant documentation for more instructions.
+ # If, for example, you only want to fetch the Unvanquished and Xonotic gamepacks,
+ # use -DGAMEPACKS_LICENSE_LIST=none and -DGAMEPACKS_NAME_LIST="Unvanquished Xonotic".
+ # See https://gitlab.com/xonotic/netradiant for more options.
cmake -G "Unix Makefiles" -S. -Bbuild \
-DCMAKE_BUILD_TYPE=Release \
-DOpenGL_GL_PREFERENCE="GLVND" \