summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-05-06 15:05:05 +0800
committerzxp198210052024-05-06 15:05:05 +0800
commitd7bd3f8bb47329420e7d5529ec4f7b39b770046b (patch)
treefac42cdeeef6afabe65fb8a76b151c6efa639e2f
parent3dab0779961b95ea197e7bf1414af59d992eb68a (diff)
downloadaur-netron-bin.tar.gz
update to 7.6.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rw-r--r--netron.sh19
3 files changed, 25 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 613510d90e32..a588a4a3a063 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = netron-bin
pkgdesc = Visualizer for neural network, deep learning and machine learning models
- pkgver = 7.6.3
+ pkgver = 7.6.4
pkgrel = 1
url = https://netron.app/
arch = x86_64
license = MIT
depends = electron30
- provides = netron=7.6.3
+ provides = netron=7.6.4
conflicts = netron
- source = netron-7.6.3.AppImage::https://github.com/lutzroeder/netron/releases/download/v7.6.3/Netron-7.6.3.AppImage
- source = LICENSE-7.6.3::https://raw.githubusercontent.com/lutzroeder/netron/v7.6.3/LICENSE
+ source = netron-7.6.4.AppImage::https://github.com/lutzroeder/netron/releases/download/v7.6.4/Netron-7.6.4.AppImage
+ source = LICENSE-7.6.4::https://raw.githubusercontent.com/lutzroeder/netron/v7.6.4/LICENSE
source = netron.sh
- sha256sums = 58178635af1e361d2e16149f59561c1fa51e1aa61d8fe87505a203e5e3f73871
+ sha256sums = baa2786b72ea83b1120a3eccb5091863945c15a215997d0fac460b8c65dc844e
sha256sums = 535cb2c7c8990f967c106e3035e4df8d3e070144af1163b86c8bb58b65fe5e88
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a
pkgname = netron-bin
diff --git a/PKGBUILD b/PKGBUILD
index aa96f7cb31b4..b538ceb4459d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=netron-bin
_pkgname=Netron
-pkgver=7.6.3
+pkgver=7.6.4
_electronversion=30
pkgrel=1
pkgdesc="Visualizer for neural network, deep learning and machine learning models"
@@ -23,9 +23,9 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/lutzroeder/netron/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('58178635af1e361d2e16149f59561c1fa51e1aa61d8fe87505a203e5e3f73871'
+sha256sums=('baa2786b72ea83b1120a3eccb5091863945c15a215997d0fac460b8c65dc844e'
'535cb2c7c8990f967c106e3035e4df8d3e070144af1163b86c8bb58b65fe5e88'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '05762c556c85a4423b28600ccbbe7b7dcdd3d1be526ef4a588a510671fa6c62a')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/netron.sh b/netron.sh
index 7ddcaab8d734..5594e5380ba2 100644
--- a/netron.sh
+++ b/netron.sh
@@ -7,10 +7,23 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+declare -a flags
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ mapfile -t < "${_FLAGS_FILE}"
+fi
+for line in "${MAPFILE[@]}"; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
+ flags+=("${line}")
+ fi
+done
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file