summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeddy Schmitz2016-11-17 16:23:39 +0800
committerTeddy Schmitz2016-11-17 16:23:39 +0800
commitc9b3a9b2ee165e6722b91c22f766360a1b389541 (patch)
tree0b361020badb6393a6ace87d8568f074f013da61
downloadaur-neuropol-ttf.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--neuropol-ttf.install23
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee7a5949ef50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neuropol-ttf
+ pkgdesc = Neuropol custom font
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.dafont.com/neuropol.font
+ install = neuropol-ttf.install
+ arch = any
+ license = custom
+ provides = ttf-font
+ source = neuropol.zip::http://dl.dafont.com/dl/?f=neuropol
+ md5sums = d4be833b0d1f63af687878951982bd6c
+
+pkgname = neuropol-ttf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..555ce406ee8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Teddy Schmitz <teddy@schmitz.hk>
+pkgname=neuropol-ttf
+pkgver=1.0
+pkgrel=1
+url="http://www.dafont.com/neuropol.font"
+license=('custom')
+pkgdesc='Neuropol custom font'
+provides=('ttf-font')
+arch=('any')
+source=("neuropol.zip::http://dl.dafont.com/dl/?f=neuropol")
+install=$pkgname.install
+md5sums=('d4be833b0d1f63af687878951982bd6c')
+
+prepare() {
+ mv "neuropol.ttf" "Neuropol.ttf"
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+ install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -Dm644 "${srcdir}"/Neuropol.ttf "${pkgdir}"/usr/share/fonts/TTF/
+ install -Dm644 typodermic-eula-02-2014.pdf "${pkgdir}"/usr/share/licenses/${pkgname}/
+}
diff --git a/neuropol-ttf.install b/neuropol-ttf.install
new file mode 100644
index 000000000000..32e89da42971
--- /dev/null
+++ b/neuropol-ttf.install
@@ -0,0 +1,23 @@
+post_install() {
+ echo -n "rebuilding font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ echo -n "rebuilding font cache... "
+ fc-cache /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_remove() {
+ echo -n "rebuilding font cache... "
+ fc-cache /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}