aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorremspoor2016-10-22 01:06:28 +0200
committerremspoor2016-10-22 01:06:28 +0200
commit2cb30568ac1c19bd9c08f881cc2575f2b96e5cb5 (patch)
tree680f8f428c440bdd863fe859d223d239c6b27669
parent29a771ad5490a759c2f88ff81df4220551fcae78 (diff)
downloadaur-2cb30568ac1c19bd9c08f881cc2575f2b96e5cb5.tar.gz
Created small script to start neXt.x86*
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--next.desktop2
-rw-r--r--next.sh4
4 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25fb1e16f876..d0b830323ef7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,11 @@ pkgbase = next
optdepends = joyutils: jscal, jstest, and jsattach utilities for the Linux joystick driver
source = http://www.cgm-online.com/secure_rc-heli-simulator/cgm-rc-heli-simulator-linux-x86-64bit.zip
source = next.desktop
+ source = next.sh
source = next.LICENSE
sha256sums = 9c07767316866e40099064d2ba053786e7420cdeab0cf87288c16bb3b0a0e102
- sha256sums = 3acf4a84a47c281aa77c71004a28cc7be284854c98bb302da5e52002a3cc9afd
+ sha256sums = 31972ec9835d29109e490a54b49865dd69084c5552344cfe2fec9b534a5fa8a2
+ sha256sums = 167bf2f656980495a5de69cc6fb0eb1063ddf065d021525cb73cf4e10425c2d8
sha256sums = febb1e65a7932f2f80155078b1dd64f469433625c76cff43b239768a184729f0
pkgname = next
diff --git a/PKGBUILD b/PKGBUILD
index e6a474d60549..93525b8ff276 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Rinus Remspoor <remspoor AT linuxmail DOT org>
+# Maintainer(s): remspoor <remspoor AT linuxmail DOT org>
+# Jake
pkgname=next
pkgver=1.455
@@ -11,10 +12,12 @@ optdepends=( 'joyutils: jscal, jstest, and jsattach utilities for the Linux joys
source=( 'http://www.cgm-online.com/secure_rc-heli-simulator/cgm-rc-heli-simulator-linux-x86-64bit.zip'
'next.desktop'
+ 'next.sh'
'next.LICENSE')
sha256sums=( '9c07767316866e40099064d2ba053786e7420cdeab0cf87288c16bb3b0a0e102'
- '3acf4a84a47c281aa77c71004a28cc7be284854c98bb302da5e52002a3cc9afd'
+ '31972ec9835d29109e490a54b49865dd69084c5552344cfe2fec9b534a5fa8a2'
+ '167bf2f656980495a5de69cc6fb0eb1063ddf065d021525cb73cf4e10425c2d8'
'febb1e65a7932f2f80155078b1dd64f469433625c76cff43b239768a184729f0')
prepare() {
@@ -53,12 +56,10 @@ package() {
msg2 "Installing ${pkgname}.desktop file..."
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ msg2 "Installing start script..."
+ install -Dm775 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
msg2 "Installing LICENSE file..."
# Can't find the proper license right now, maybe contact the author of the software later.
install -Dm644 ${pkgname}.LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- msg2 "Creating symlink..."
- cd "${pkgdir}/opt/${pkgname}"
- if [ -f "./neXt.x86_64" ]; then ln -s "neXt.x86_64" "${pkgname}"; fi
- if [ -f "./neXt.x86" ]; then ln -s "neXt.x86" "${pkgname}"; fi
}
diff --git a/next.desktop b/next.desktop
index d4942eb5e850..22aa3f5918f4 100644
--- a/next.desktop
+++ b/next.desktop
@@ -4,7 +4,7 @@ Name=neXt
Version=1.0
GenericName=A helicopter flight simulator made by CGM
Comment=r/c Heli Flight Simulator made by Klaus Eiperle, Eiperle CGM
-Exec=/opt/next/next
+Exec=/usr/bin/next
Terminal=false
Icon=/usr/share/pixmaps/next.png
Path=/opt/next/
diff --git a/next.sh b/next.sh
new file mode 100644
index 000000000000..83886961e78e
--- /dev/null
+++ b/next.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/next/
+./neXt.x86_64 || ./neXt.x86