summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-07-29 22:42:17 +0700
committerKonstantin Shalygin2017-07-29 22:42:17 +0700
commit58471627fad446c1c168cad4448aec116a9f5cc2 (patch)
tree5c9891425a6b0e48908ea26300329616d9232142
parent7054b44faefbdc8ad676c18a0a344bb06049e137 (diff)
downloadaur-58471627fad446c1c168cad4448aec116a9f5cc2.tar.gz
Bump to 2.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da58a501b824..15c43d749d1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 25 12:12:13 UTC 2017
+# Sat Jul 29 15:41:32 UTC 2017
pkgbase = nextcloud-client
pkgdesc = Nextcloud desktop client
- pkgver = 2.3.1
+ pkgver = 2.3.2
pkgrel = 1
url = https://nextcloud.com/
arch = i686
@@ -24,8 +24,8 @@ pkgbase = nextcloud-client
optdepends = libgnome-keyring: GNOME keyring client
conflicts = owncloud-client
backup = etc/Nextcloud/sync-exclude.lst
- source = nextcloud-client::git+https://github.com/nextcloud/client_theming.git
- sha256sums = SKIP
+ source = https://github.com/nextcloud/client_theming/archive/v2.3.2.tar.gz
+ sha256sums = fbebbcfc538654d7a5373062d2165638a9bd9e5dbe62b5f4552a942b0b931617
pkgname = nextcloud-client
diff --git a/PKGBUILD b/PKGBUILD
index 2f6f03a78dbf..aa89a8b19a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgname='nextcloud-client'
-pkgver='2.3.1'
+pkgver='2.3.2'
pkgrel='1'
pkgdesc='Nextcloud desktop client'
arch=('i686' 'x86_64')
@@ -15,34 +15,34 @@ optdepends=('python2-nautilus: integration with Nautilus'
'kio: Resource and network access abstraction (KDE)'
'libgnome-keyring: GNOME keyring client')
conflicts=('owncloud-client')
-source=("${pkgname}::git+https://github.com/nextcloud/client_theming.git")
-sha256sums=('SKIP')
+source=("https://github.com/nextcloud/client_theming/archive/v${pkgver}.tar.gz")
+sha256sums=('fbebbcfc538654d7a5373062d2165638a9bd9e5dbe62b5f4552a942b0b931617')
backup=('etc/Nextcloud/sync-exclude.lst')
prepare() {
- cd "${srcdir}/${pkgname}"
+ mkdir -p "${srcdir}/client_theming-${pkgver}/build-linux"
+ git clone git://github.com/owncloud/client.git "${srcdir}/client_theming-${pkgver}/client"
+ cd "${srcdir}/client_theming-${pkgver}/client"
git submodule update --init --recursive
- mkdir -p "${srcdir}/${pkgname}/build-linux"
}
build() {
- cd "${srcdir}/${pkgname}/build-linux"
+ cd "${srcdir}/client_theming-${pkgver}/build-linux"
- cmake -D OEM_THEME_DIR=${srcdir}/${pkgname}/nextcloudtheme ../client \
+ cmake -D OEM_THEME_DIR="${srcdir}/client_theming-${pkgver}/nextcloudtheme" ../client \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
-
make
make doc-man
}
check() {
- sed -Ei 's|Icon(\[.*\])?=nextcloud|Icon\1=Nextcloud|g' "${srcdir}/${pkgname}/build-linux/src/gui/nextcloud.desktop"
+ sed -Ei 's|Icon(\[.*\])?=nextcloud|Icon\1=Nextcloud|g' "${srcdir}/client_theming-${pkgver}/build-linux/src/gui/nextcloud.desktop"
}
package() {
- cd "${srcdir}/${pkgname}/build-linux"
+ cd "${srcdir}/client_theming-${pkgver}/build-linux"
make DESTDIR="${pkgdir}" install
}