summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-11-14 17:06:08 +0700
committerKonstantin Shalygin2018-11-14 17:06:08 +0700
commit6dc96d879153220e026f464ed806c3e2f779eff6 (patch)
tree9675a534dac68294d153c0c247cd125ae423791b
parentaca8698d193f4fea51c941662829183c511fbd12 (diff)
downloadaur-6dc96d879153220e026f464ed806c3e2f779eff6.tar.gz
Bump to 2.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 19 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd9f56bffad..69ad3c3c43de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,27 @@
# Generated by mksrcinfo v8
-# Fri Nov 24 11:52:11 UTC 2017
+# Wed Nov 14 10:05:52 UTC 2018
pkgbase = nextcloud-client
pkgdesc = Nextcloud desktop client
- pkgver = 2.3.3
+ pkgver = 2.5.0
pkgrel = 1
url = https://nextcloud.com/
arch = i686
arch = x86_64
license = GPL2
- makedepends = git
makedepends = extra-cmake-modules
makedepends = python-sphinx
makedepends = qt5-tools
makedepends = doxygen
- makedepends = qtkeychain
- depends = qt5-webkit
- depends = hicolor-icon-theme
- depends = xdg-utils
+ depends = qt5-webengine
depends = qtkeychain
+ depends = kio
optdepends = python2-nautilus: integration with Nautilus
optdepends = nemo-python: integration with Nemo
- optdepends = kio: Resource and network access abstraction (KDE)
optdepends = libgnome-keyring: GNOME keyring client
conflicts = owncloud-client
backup = etc/Nextcloud/sync-exclude.lst
- source = https://github.com/nextcloud/client_theming/archive/v2.3.3.tar.gz
- sha256sums = e3c4393095206648c96980fb23d0520658b3aa8a9a1e31db38b6f59024cb6f8b
+ source = https://github.com/nextcloud/desktop/archive/v2.5.0.tar.gz
+ sha256sums = 4d639f43e49fd4367cd1b99bf21aecb2eac3bd89a7b0d96c7d2a0975baad6528
pkgname = nextcloud-client
diff --git a/PKGBUILD b/PKGBUILD
index d276b0d19b57..0060a9ef6e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,40 @@
# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
-_next_commit='57bc7918d7b0650c116f3512787f7677d4e5ab17'
pkgname='nextcloud-client'
-pkgver='2.3.3'
+pkgver='2.5.0'
pkgrel='1'
pkgdesc='Nextcloud desktop client'
arch=('i686' 'x86_64')
url='https://nextcloud.com/'
license=('GPL2')
-depends=('qt5-webkit' 'hicolor-icon-theme' 'xdg-utils' 'qtkeychain')
-makedepends=('git' 'extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen' 'qtkeychain')
+depends=('qt5-webengine' 'qtkeychain' 'kio')
+makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen')
optdepends=('python2-nautilus: integration with Nautilus'
'nemo-python: integration with Nemo'
- 'kio: Resource and network access abstraction (KDE)'
'libgnome-keyring: GNOME keyring client')
conflicts=('owncloud-client')
-source=("https://github.com/nextcloud/client_theming/archive/v${pkgver}.tar.gz")
-sha256sums=('e3c4393095206648c96980fb23d0520658b3aa8a9a1e31db38b6f59024cb6f8b')
+source=("https://github.com/nextcloud/desktop/archive/v${pkgver}.tar.gz")
+sha256sums=('4d639f43e49fd4367cd1b99bf21aecb2eac3bd89a7b0d96c7d2a0975baad6528')
backup=('etc/Nextcloud/sync-exclude.lst')
prepare() {
- mkdir -p "${srcdir}/client_theming-${pkgver}/build-linux"
- git clone git://github.com/owncloud/client.git "${srcdir}/client_theming-${pkgver}/client"
- cd "${srcdir}/client_theming-${pkgver}/client"
- git checkout "${_next_commit}"
- git submodule update --init --recursive
+ mkdir -p "${srcdir}/desktop-${pkgver}/build"
}
build() {
- cd "${srcdir}/client_theming-${pkgver}/build-linux"
+ cd "${srcdir}/desktop-${pkgver}/build"
- cmake -D OEM_THEME_DIR="${srcdir}/client_theming-${pkgver}/nextcloudtheme" ../client \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
make
make doc-man
}
-check() {
- sed -Ei 's|Icon(\[.*\])?=nextcloud|Icon\1=Nextcloud|g' "${srcdir}/client_theming-${pkgver}/build-linux/src/gui/nextcloud.desktop"
-}
-
package() {
- cd "${srcdir}/client_theming-${pkgver}/build-linux"
+ cd "${srcdir}/desktop-${pkgver}/build"
make DESTDIR="${pkgdir}" install
}