summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-06-03 15:22:53 +0200
committerBłażej Szczygieł2016-06-03 15:22:53 +0200
commit3fff7bca36c3dec237a10451273a398a4486c42e (patch)
tree324d13c040812219821bdbbce25f4e9f5f729c1b
downloadaur-3fff7bca36c3dec237a10451273a398a4486c42e.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--Need For Speed II SE.desktop6
-rw-r--r--PKGBUILD39
-rwxr-xr-xnfs2se2
-rw-r--r--nfs2se-git.install13
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ece477f27e52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 13:22:19 UTC 2016
+pkgbase = nfs2se-git
+ pkgdesc = Need For Speed II SE - Linux port with 3D acceleration and TCP protocol!
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/zaps166/NFSIISE
+ install = nfs2se-git.install
+ arch = i686
+ arch = x86_64
+ makedepends = gcc
+ makedepends = yasm
+ depends = sdl2
+ depends = libgl
+ source = git+https://github.com/zaps166/NFSIISE
+ source = Need For Speed II SE.desktop
+ source = nfs2se
+ md5sums = SKIP
+ md5sums = cb242d0c0a39b503c3bd44800240567e
+ md5sums = 50da45b125bd78839b60b9a16989c37f
+
+pkgname = nfs2se-git
+
diff --git a/Need For Speed II SE.desktop b/Need For Speed II SE.desktop
new file mode 100644
index 000000000000..b61e008aa7dd
--- /dev/null
+++ b/Need For Speed II SE.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Need For Speed II SE
+Type=Application
+Terminal=false
+Icon=nfs2se
+Exec=nfs2se
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1dd3956d631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: zaps166 <spaz16@wp.pl>
+
+pkgname=nfs2se-git
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Need For Speed II SE - Linux port with 3D acceleration and TCP protocol!'
+arch=('i686' 'x86_64')
+url='https://github.com/zaps166/NFSIISE'
+depends=('sdl2' 'libgl')
+makedepends=('gcc' 'yasm')
+source=('git+https://github.com/zaps166/NFSIISE'
+ 'Need For Speed II SE.desktop'
+ 'nfs2se')
+md5sums=('SKIP'
+ 'cb242d0c0a39b503c3bd44800240567e'
+ '50da45b125bd78839b60b9a16989c37f')
+install=nfs2se-git.install
+
+build()
+{
+ cd $srcdir/NFSIISE
+ ./compile_nfs
+}
+
+package()
+{
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/nfs2se $pkgdir/usr/bin
+
+ mkdir $pkgdir/opt
+ cp -r "$srcdir/NFSIISE/Need For Speed II SE" $pkgdir/opt/nfs2se
+ rm -f $pkgdir/opt/nfs2se/open_config.bat
+
+ mkdir -p $pkgdir/usr/share/applications
+ cp "$srcdir/Need For Speed II SE.desktop" $pkgdir/usr/share/applications
+
+ mkdir -p $pkgdir/usr/share/icons/hicolor/32x32/apps
+ mv $pkgdir/opt/nfs2se/nfs2se.png $pkgdir/usr/share/icons/hicolor/32x32/apps
+}
diff --git a/nfs2se b/nfs2se
new file mode 100755
index 000000000000..0ad7f542365a
--- /dev/null
+++ b/nfs2se
@@ -0,0 +1,2 @@
+#!/bin/sh
+cd /opt/nfs2se && exec ./nfs2se
diff --git a/nfs2se-git.install b/nfs2se-git.install
new file mode 100644
index 000000000000..4b4bcf7d0232
--- /dev/null
+++ b/nfs2se-git.install
@@ -0,0 +1,13 @@
+post_install()
+{
+ echo 'Copy the "gamedata" and "fedata" directories from original game CD-ROM to "/opt/nfs2se".'
+ echo 'You can also create a symlink for them from your home directory.'
+ echo 'Be sure that all files and directories have small letters!'
+ echo
+ echo 'The configuration data is in "~/.nfs2se" directory (after first run).'
+}
+
+post_upgrade()
+{
+ post_install
+}