summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-07-15 22:39:48 +0200
committerBłażej Szczygieł2016-07-15 22:39:48 +0200
commit9cf9c716d148e02dee99d240e2ba640d8707539d (patch)
tree2c2bba43b6c4a3acead924f1986d4e336e5c1669
parent12f960e98d12aca26506c017dd3429b92bfcf38a (diff)
downloadaur-9cf9c716d148e02dee99d240e2ba640d8707539d.tar.gz
Follow GitHub changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 730464b2b2c3..121a50c1c8e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 11:33:31 UTC 2016
+# Fri Jul 15 20:39:04 UTC 2016
pkgbase = nfs2se-git
pkgdesc = Cross-platform wrapper for the Need For Speed™ II SE game with 3D acceleration and TCP protocol!
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zaps166/NFSIISE
install = nfs2se-git.install
arch = i686
arch = x86_64
license = MIT
makedepends = gcc-multilib
- makedepends = curl
+ makedepends = yasm
depends = lib32-sdl2
depends = lib32-libgl
source = git+https://github.com/zaps166/NFSIISE
diff --git a/PKGBUILD b/PKGBUILD
index bf0a06c9158c..bc12401660c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nfs2se-git
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Cross-platform wrapper for the Need For Speed™ II SE game with 3D acceleration and TCP protocol!'
arch=('i686' 'x86_64')
url='https://github.com/zaps166/NFSIISE'
@@ -10,10 +10,10 @@ license=('MIT')
if [ $(uname -m) == "x86_64" ]; then
depends=('lib32-sdl2' 'lib32-libgl')
- makedepends=('gcc-multilib' 'curl')
+ makedepends=('gcc-multilib' 'yasm')
else
depends=('sdl2' 'libgl')
- makedepends=('gcc' 'curl')
+ makedepends=('gcc' 'yasm')
fi
source=('git+https://github.com/zaps166/NFSIISE'
@@ -25,6 +25,8 @@ install=nfs2se-git.install
build()
{
cd $srcdir/NFSIISE
+ git submodule init
+ git submodule update
./compile_nfs
}