summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoàng Đức Hiếu2017-10-15 09:49:08 +0700
committerHoàng Đức Hiếu2017-10-15 09:50:54 +0700
commit6d6399919c5bcb61bb652f0668ddad464a8b52f3 (patch)
tree1300299483e2384b046d63e0b54b30e4410db3fb
parent99ff275a8ae046dca18686895a36f059e2d2b1ec (diff)
downloadaur-6d6399919c5bcb61bb652f0668ddad464a8b52f3.tar.gz
check nginx integrity by PGP key
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
3 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8d09e7b356c..fdee9f4cb5fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-fancyindex
pkgdesc = Fancy indexes module for the Nginx web server
pkgver = 0.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aperezdc/ngx-fancyindex
arch = i686
arch = x86_64
@@ -9,8 +9,11 @@ pkgbase = nginx-mainline-mod-fancyindex
license = BSD
depends = nginx-mainline
source = https://nginx.org/download/nginx-1.13.4.tar.gz
+ source = https://nginx.org/download/nginx-1.13.4.tar.gz.asc
source = https://github.com/aperezdc/ngx-fancyindex/archive/v0.4.2.tar.gz
- sha256sums = de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 8327150864ca267b735d550d3304030efbbd863fdddfe0a94e970f249a8827ee
pkgname = nginx-mainline-mod-fancyindex
diff --git a/.gitignore b/.gitignore
index a1aa878196ae..040df18b9f2a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*z
+*.asc
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 83be7ab57c90..6d7d6c559468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nginx-mainline-mod-fancyindex
pkgver=0.4.2
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -14,9 +14,12 @@ url="https://github.com/aperezdc/ngx-fancyindex"
license=('BSD')
source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
https://github.com/aperezdc/ngx-$_modname/archive/v$pkgver.tar.gz
)
+sha256sums=('SKIP' 'SKIP'
+ '8327150864ca267b735d550d3304030efbbd863fdddfe0a94e970f249a8827ee')
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8') # Maxim Dounin <mdounin@mdounin.ru>
prepare() {
cd ngx-$_modname-$pkgver
@@ -40,5 +43,3 @@ package() {
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done
}
-sha256sums=('de21f3c49ba65c611329d8759a63d72e5fcf719bc6f2a3270e2541348ef1fbba'
- '8327150864ca267b735d550d3304030efbbd863fdddfe0a94e970f249a8827ee')