summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2022-06-23 22:48:46 +0200
committerJeremy Kescher2022-06-23 22:48:46 +0200
commit301f8e2fb211a10cbd666d8f06a54717b01cc0f9 (patch)
tree82e632e683862097c7b1efd210bf482950c98078
downloadaur-nginx-mainline-mod-headers-more-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51f46b448765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nginx-mainline-mod-headers-more-git
+ pkgdesc = Set and clear input and output headers (module for mainline nginx)
+ pkgver = 0.33.r15.ge536bc5
+ pkgrel = 1
+ url = https://github.com/openresty/headers-more-nginx-module
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = nginx-mainline-src
+ depends = nginx-mainline
+ source = headers-more-nginx-module::git+https://github.com/openresty/headers-more-nginx-module.git
+ sha256sums = SKIP
+
+pkgname = nginx-mainline-mod-headers-more-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58a234a1e76d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jeremy Kescher <jeremy@kescher.at>
+
+pkgname=nginx-mainline-mod-headers-more-git
+pkgver=0.33.r15.ge536bc5
+pkgrel=1
+
+pkgdesc="Set and clear input and output headers (module for mainline nginx)"
+arch=('i686' 'x86_64')
+depends=('nginx-mainline')
+makedepends=('nginx-mainline-src')
+url="https://github.com/openresty/headers-more-nginx-module"
+license=('BSD')
+sha256sums=('SKIP')
+
+source=(headers-more-nginx-module::git+https://github.com/openresty/headers-more-nginx-module.git)
+
+pkgver() {
+ cd headers-more-nginx-module
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p build
+ cd build
+ ln -sf /usr/src/nginx/auto
+ ln -sf /usr/src/nginx/src
+}
+
+build() {
+ cd build
+ /usr/src/nginx/configure --with-compat --add-dynamic-module="$srcdir"/headers-more-nginx-module
+ make modules
+}
+
+package() {
+ cd build/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}