summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2020-12-28 19:59:40 +0100
committerMassimiliano Torromeo2020-12-28 19:59:40 +0100
commit2d2ae38742c36605fb9532ad4dd9239f7e2ae220 (patch)
tree290215c734422da06a3af266ab0f559551ce2cf5
parentd7ea4631ae8527b0c0529e84a6dde1d760cc8c2d (diff)
downloadaur-nginx-mainline-mod-srcache.tar.gz
Updated to build against nginx-mainline-mod-src
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a415ce590673..9a38fc4f839c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = nginx-mainline-mod-srcache
pkgdesc = Transparent subrequest-based caching layout for arbitrary nginx locations (module for mainline nginx)
pkgver = 0.31
- pkgrel = 38
+ pkgrel = 39
url = https://github.com/openresty/srcache-nginx-module
arch = i686
arch = x86_64
license = BSD
+ makedepends = nginx-mainline-src
depends = nginx-mainline
- source = https://nginx.org/download/nginx-1.19.3.tar.gz
- source = https://nginx.org/download/nginx-1.19.3.tar.gz.asc
source = https://github.com/openresty/srcache-nginx-module/archive/v0.31/srcache-0.31.tar.gz
- validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = 91e5b74fa17879d2463294e93ad8f6ffc066696ae32ad0478ffe15ba0e9e8df0
- sha256sums = SKIP
sha256sums = 3f9729e73a8340926fa9d9fc15707c2f287cd27b6a9fe42e83f660ca48a5972d
pkgname = nginx-mainline-mod-srcache
diff --git a/PKGBUILD b/PKGBUILD
index b972a9789d61..3a8770480698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,35 @@
pkgname=nginx-mainline-mod-srcache
pkgver=0.31
-pkgrel=38
+pkgrel=39
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.19.3
pkgdesc='Transparent subrequest-based caching layout for arbitrary nginx locations (module for mainline nginx)'
arch=('i686' 'x86_64')
depends=('nginx-mainline')
+makedepends=('nginx-mainline-src')
url="https://github.com/openresty/srcache-nginx-module"
license=('BSD')
-source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
- https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
-)
+source=(https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz)
+sha256sums=('3f9729e73a8340926fa9d9fc15707c2f287cd27b6a9fe42e83f660ca48a5972d')
-validpgpkeys=(
- 'B0F4253373F8F6F510D42178520A9993A1C052F8' # Maxim Dounin <mdounin@mdounin.ru>
-)
-
-sha256sums=('91e5b74fa17879d2463294e93ad8f6ffc066696ae32ad0478ffe15ba0e9e8df0'
- 'SKIP'
- '3f9729e73a8340926fa9d9fc15707c2f287cd27b6a9fe42e83f660ca48a5972d')
+prepare() {
+ mkdir -p build
+ cd build
+ ln -sf /usr/src/nginx/auto
+ ln -sf /usr/src/nginx/src
+}
build() {
- cd "$srcdir"/nginx-$_nginxver
- ./configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ cd build
+ /usr/src/nginx/configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
make modules
}
package() {
- cd "$srcdir"/nginx-$_nginxver/objs
+ cd build/objs
for mod in *.so; do
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done