summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-10-27 03:03:19 -0400
committerJames An2016-10-27 03:03:19 -0400
commit29d0e35068eced49110673282cb9af66fa04a402 (patch)
tree084f7bde6ae9a78e31945068cc82d01c93ce13ac
downloadaur-nginx-upload-progress-module-git.tar.gz
Initial commit with working package.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD89
-rw-r--r--config16
4 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4d165cd867b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nginx-upload-progress-module-git
+ pkgdesc = Module for nginx web server for handling file uploads using multipart/form-data encoding (RFC 1867)
+ pkgver = v0.9.2.r2.gafb2d31
+ pkgrel = 1
+ url = http://wiki.codemongers.com/NginxHttpUploadProgressModule
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ provides = nginx-upload-progress-module=v0.9.2.r2.gafb2d31
+ conflicts = nginx-upload-progress-module
+ source = nginx-upload-progress-module::git+https://github.com/masterzen/nginx-upload-progress-module.git
+ source = http://nginx.org/download/nginx-1.10.2.tar.gz
+ md5sums = SKIP
+ md5sums = e8f5f4beed041e63eb97f9f4f55f3085
+
+pkgname = nginx-upload-progress-module-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..090410c35c7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=nginx-upload-progress-module-git
+_pkgname=${pkgname%-git}
+pkgver=v0.9.2.r2.gafb2d31
+pkgrel=1
+pkgdesc="Module for nginx web server for handling file uploads using multipart/form-data encoding (RFC 1867)"
+arch=('i686' 'x86_64')
+url="http://wiki.codemongers.com/NginxHttpUploadProgressModule"
+license=('BSD')
+depends=()
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=()
+install=
+source=("$_pkgname"::"git+https://github.com/masterzen/$_pkgname.git"
+ http://nginx.org/download/nginx-1.10.2.tar.gz)
+md5sums=('SKIP'
+ 'e8f5f4beed041e63eb97f9f4f55f3085')
+
+_common_flags=(
+ --with-ipv6
+ --with-pcre-jit
+ --with-file-aio
+ --with-http_addition_module
+ --with-http_auth_request_module
+ --with-http_dav_module
+ --with-http_degradation_module
+ --with-http_flv_module
+ --with-http_geoip_module
+ --with-http_gunzip_module
+ --with-http_gzip_static_module
+ --with-http_mp4_module
+ --with-http_realip_module
+ --with-http_secure_link_module
+ --with-http_ssl_module
+ --with-http_stub_status_module
+ --with-http_sub_module
+ --with-http_v2_module
+ --with-mail
+ --with-mail_ssl_module
+ --with-stream
+ --with-stream_ssl_module
+ --with-threads
+)
+
+_stable_flags=(
+)
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd nginx-1.10.2
+
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ ${_common_flags[@]} \
+ ${_stable_flags[@]} \
+ --add-dynamic-module="$srcdir/$_pkgname"
+
+ make modules
+}
+
+package() {
+ cd nginx-1.10.2
+
+ install -Dm755 objs/ngx_http_uploadprogress_module.so "$pkgdir/etc/nginx/modules/ngx_http_uploadprogress_module.so"
+}
diff --git a/config b/config
new file mode 100644
index 000000000000..2eee34cfd2dc
--- /dev/null
+++ b/config
@@ -0,0 +1,16 @@
+# From: https://github.com/vkholodkov/nginx-upload-module/issues/78
+
+USE_MD5=YES
+USE_SHA1=YES
+ngx_addon_name=ngx_http_upload_module
+
+if test -n "$ngx_module_link"; then
+ ngx_module_type=HTTP
+ ngx_module_name=ngx_http_upload_module
+ ngx_module_srcs="$ngx_addon_dir/ngx_http_upload_module.c"
+
+ . auto/module
+else
+ HTTP_MODULES="$HTTP_MODULES ngx_http_upload_module"
+ NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/ngx_http_upload_module.c"
+fi