summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranekos2020-05-08 20:58:27 +0900
committeranekos2020-05-08 20:59:41 +0900
commite29cca54b9ff1de70355b723dd95c993eab1ee82 (patch)
treeb12425a41bc5d6d0878a558a6db3e555a6c60e9e
downloadaur-ngt-git.tar.gz
PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d77f989d2e3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ngt-git
+ pkgdesc = Nearest Neighbor Search with Neighborhood Graph and Tree for High-dimensional Data
+ pkgver = 20200508
+ pkgrel = 3
+ url = https://github.com/yahoojapan/NGT
+ arch = i686
+ arch = x86_64
+ license = Apache_v2
+ makedepends = cmake
+ makedepends = git
+ source = ngt-git::git+https://github.com/yahoojapan/NGT/
+ md5sums = SKIP
+
+pkgname = ngt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfb6f895cfbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: anekos <anekos@snca.net>
+pkgname=ngt-git
+pkgver=20200508
+pkgrel=3
+pkgdesc="Nearest Neighbor Search with Neighborhood Graph and Tree for High-dimensional Data"
+url="https://github.com/yahoojapan/NGT"
+arch=('i686' 'x86_64')
+license=('Apache_v2')
+source=("$pkgname::git+https://github.com/yahoojapan/NGT/")
+md5sums=('SKIP')
+makedepends=('cmake' 'git')
+
+
+build () {
+ cd $srcdir/$pkgname
+
+ # git checkout v1.7.8
+
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" .
+ make
+}
+
+package () {
+ cd $srcdir/$pkgname
+
+ make install
+}
+
+# vim:set ts=2 sw=2 et:
+
+