summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Donofry2021-11-16 23:44:14 -0500
committerJoseph Donofry2021-11-16 23:44:14 -0500
commit59b803863d573954c808dbcdb4ae0163977b5068 (patch)
tree97f0082f699df0a979a619941df81ad300e774b9
parent06267edb5f8aac62e87389cf6e639f30ea97ebfe (diff)
downloadaur-59b803863d573954c808dbcdb4ae0163977b5068.tar.gz
Add qt-jdenticon optdepends and remove cmake variable in build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58d0ac0fc7bd..1381a8f30db1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheko-git
pkgdesc = Desktop client for the Matrix protocol
- pkgver = 0.8.2.r386.g35b36e24
+ pkgver = 0.8.2.r786.gc40fbf42
pkgrel = 1
url = https://github.com/Nheko-Reborn/nheko
arch = i686
@@ -34,6 +34,7 @@ pkgbase = nheko-git
depends = spdlog
depends = curl
depends = libevent
+ optdepends = qt-jdenticon
provides = nheko
conflicts = nheko
source = nheko-git::git+https://github.com/Nheko-Reborn/nheko.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index d1b49ba7495d..13a194b59106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Joseph Donofry <joe at joedonofry dot com>
pkgname=nheko-git
-pkgver=0.8.2.r386.g35b36e24
+pkgver=0.8.2.r786.gc40fbf42
pkgrel=1
pkgdesc="Desktop client for the Matrix protocol"
arch=("i686" "x86_64" "aarch64")
@@ -12,7 +12,7 @@ license=("GPL3")
depends=("qt5-base" "lmdb" "qt5-graphicaleffects" "qt5-multimedia" "qt5-svg" "qt5-quickcontrols2" "qt5-declarative" "qtkeychain-qt5" "cmark" "openssl" "hicolor-icon-theme" "gstreamer" "gst-plugins-base" "gst-plugins-good" "gst-plugins-bad" "gst-plugin-qmlgl" "libnice" "libolm" "spdlog" "curl" "libevent")
makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools" "nlohmann-json")
-
+optdepends=("qt-jdenticon")
provides=("nheko")
conflicts=("nheko")
@@ -33,8 +33,6 @@ build() {
rm -f cmake/FindOlm.cmake
- # build with more cores than the default
- export CMAKE_BUILD_PARALLEL_LEVEL=$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
cmake -H. -Bbuild -DHUNTER_ENABLED=OFF -DBUILD_SHARED_LIBS=OFF -DUSE_BUNDLED_MTXCLIENT=ON -DUSE_BUNDLED_COEURL=ON -DUSE_BUNDLED_LMDBXX=ON -DCMAKE_INSTALL_PREFIX=.deps/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build --config Release
}