summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Donofry2021-07-01 20:29:46 -0400
committerJoseph Donofry2021-07-01 20:29:57 -0400
commitab0e72ae9ee32d8e1c2c4163bc4d8e94aecd6386 (patch)
tree049eccb6464e8b7f08cf54107d37f86f6d21f899
parentfad8f206cced3038cb112cae9ee3c144bc40d79c (diff)
downloadaur-ab0e72ae9ee32d8e1c2c4163bc4d8e94aecd6386.tar.gz
Update Dependencies
mtxclient no longer depends on boost and instead uses a custom library (coeurl) built on top of curl. As such, curl and libevent are now required.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b611876d477e..8b721116e966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheko-git
pkgdesc = Desktop client for the Matrix protocol
- pkgver = 0.8.2.r156.gfddc558b
+ pkgver = 0.8.2.r169.g5b016cbc
pkgrel = 1
url = https://github.com/Nheko-Reborn/nheko
arch = i686
@@ -12,7 +12,6 @@ pkgbase = nheko-git
makedepends = fontconfig
makedepends = qt5-tools
makedepends = nlohmann-json
- makedepends = boost
depends = qt5-base
depends = lmdb
depends = qt5-graphicaleffects
@@ -21,7 +20,6 @@ pkgbase = nheko-git
depends = qt5-quickcontrols2
depends = qt5-declarative
depends = qtkeychain-qt5
- depends = boost-libs
depends = cmark
depends = openssl
depends = hicolor-icon-theme
@@ -32,10 +30,11 @@ pkgbase = nheko-git
depends = libnice
depends = libolm
depends = spdlog
+ depends = curl
+ depends = libevent
provides = nheko
conflicts = nheko
source = nheko-git::git+https://github.com/Nheko-Reborn/nheko.git#branch=master
md5sums = SKIP
pkgname = nheko-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d2d1e400fae..71ed40f475b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Joseph Donofry <joe at joedonofry dot com>
pkgname=nheko-git
-pkgver=0.8.2.r156.gfddc558b
+pkgver=0.8.2.r169.g5b016cbc
pkgrel=1
pkgdesc="Desktop client for the Matrix protocol"
arch=("i686" "x86_64")
@@ -10,8 +10,8 @@ arch=("i686" "x86_64")
url="https://github.com/Nheko-Reborn/nheko"
license=("GPL3")
-depends=("qt5-base" "lmdb" "qt5-graphicaleffects" "qt5-multimedia" "qt5-svg" "qt5-quickcontrols2" "qt5-declarative" "qtkeychain-qt5" "boost-libs" "cmark" "openssl" "hicolor-icon-theme" "gstreamer" "gst-plugins-base" "gst-plugins-good" "gst-plugins-bad" "libnice" "libolm" "spdlog" )
-makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools" "nlohmann-json" "boost")
+depends=("qt5-base" "lmdb" "qt5-graphicaleffects" "qt5-multimedia" "qt5-svg" "qt5-quickcontrols2" "qt5-declarative" "qtkeychain-qt5" "cmark" "openssl" "hicolor-icon-theme" "gstreamer" "gst-plugins-base" "gst-plugins-good" "gst-plugins-bad" "libnice" "libolm" "spdlog" "curl" "libevent")
+makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools" "nlohmann-json")
provides=("nheko")
conflicts=("nheko")
@@ -35,7 +35,7 @@ build() {
# build with more cores than the default
export CMAKE_BUILD_PARALLEL_LEVEL=$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
- cmake -H. -Bbuild -DHUNTER_ENABLED=OFF -DBUILD_SHARED_LIBS=OFF -DUSE_BUNDLED_MTXCLIENT=ON -DUSE_BUNDLED_LMDBXX=ON -DCMAKE_INSTALL_PREFIX=.deps/usr -DCMAKE_BUILD_TYPE=Release
+ cmake -H. -Bbuild -DHUNTER_ENABLED=OFF -DBUILD_SHARED_LIBS=OFF -DUSE_BUNDLED_MTXCLIENT=ON -DUSE_BUNDLED_COEURL=ON -DUSE_BUNDLED_LMDBXX=ON -DCMAKE_INSTALL_PREFIX=.deps/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build --config Release
}