aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-09-01 15:04:20 +0100
committerGrey Christoforo2015-09-01 15:04:20 +0100
commit69ea865a13e625cef83e5c23f3359799d2b0136f (patch)
treeecfc9bcc3417a3c92fcc1681a728f7b30990c2ec
downloadaur-69ea865a13e625cef83e5c23f3359799d2b0136f.tar.gz
initial attempt at installing ni-visa
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61958f0d05ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ni-visa
+ pkgdesc = National Instruments NI-VISA(TM) Software for Linux
+ pkgver = 15.0.0
+ pkgrel = 1
+ url = http://www.ni.com/download/ni-visa-5.4.1/4629/en/
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ source = http://download.ni.com/support/softlib/visa/NI-VISA/15.0/Linux/NI-VISA-15.0.0.iso
+ md5sums = c1dbdfd1f32d3d995b2a75e35e3a81ac
+
+pkgname = ni-visa
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56f2a5de32f5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+.tar.xz
+.iso
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f215eb1865d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=ni-visa
+pkgver=15.0.0
+pkgrel=1
+pkgdesc="National Instruments NI-VISA(TM) Software for Linux"
+url="http://www.ni.com/download/ni-visa-5.4.1/4629/en/"
+#arch=('i686' 'x86_64')
+arch=('x86_64')
+license=('custom')
+makedepends=('rpmextract')
+depends=('')
+
+source=("http://download.ni.com/support/softlib/visa/NI-VISA/15.0/Linux/NI-VISA-${pkgver}.iso")
+md5sums=('c1dbdfd1f32d3d995b2a75e35e3a81ac')
+
+package() {
+ tar -xvf nivisa-15.0.0f1.tar.gz
+ cd rpms
+ rpmextract.sh nivisa-15.0.0-f0.x86_64.rpm
+
+ mv "${srcdir}/rpms/usr" "${pkgdir}"
+
+ #install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: