summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-03-14 11:35:29 +0000
committerAntonio Rojas2020-03-14 11:35:29 +0000
commit1fd2e6138397cba2dd5fd13e1ca4fb7e766c0d56 (patch)
tree3dae04ad025cc36fd9024c7f39b80915b21fe47b
downloadaur-nicotine+.tar.gz
Dropped from [community]
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2277386bf0a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nicotine+
+ pkgdesc = Soulseek music-sharing client, written in python
+ pkgver = 1.4.1
+ pkgrel = 4
+ url = https://github.com/Nicotine-Plus/nicotine-plus
+ arch = any
+ license = GPL
+ depends = python2-mutagen
+ depends = pygtk
+ optdepends = python2-geoip: to enable Geographical blocker
+ conflicts = nicotine
+ replaces = nicotine
+ source = nicotine+-1.4.1::https://github.com/Nicotine-Plus/nicotine-plus/archive/1.4.1.tar.gz
+ sha256sums = 1b38ef196d981e4eb96fa990cc463143289784f988f559c4400b1d461497b7d6
+
+pkgname = nicotine+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf463c9a7d58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Contributor: Andrew Wright <andreww@photism.org>
+
+pkgname=nicotine+
+pkgver=1.4.1
+pkgrel=4
+pkgdesc='Soulseek music-sharing client, written in python'
+arch=(any)
+url='https://github.com/Nicotine-Plus/nicotine-plus'
+license=(GPL)
+depends=(python2-mutagen pygtk)
+optdepends=('python2-geoip: to enable Geographical blocker')
+conflicts=(nicotine)
+replaces=(nicotine)
+source=($pkgname-$pkgver::"https://github.com/Nicotine-Plus/nicotine-plus/archive/$pkgver.tar.gz")
+sha256sums=('1b38ef196d981e4eb96fa990cc463143289784f988f559c4400b1d461497b7d6')
+
+package() {
+ cd nicotine-plus-$pkgver
+
+ python2 setup.py install --root="$pkgdir"
+}