summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2022-05-05 11:07:37 +0200
committerAstroFloyd2022-05-05 11:07:37 +0200
commit2caa5fbfa1b1e907c069f5255c9cfa58008979bd (patch)
tree0cb1c049ad9fe056d2b346bb54f70b2252607527
parent9ce211b55c0616820cbebbe04fe6be020200841d (diff)
downloadaur-nidaqmx-dummy.tar.gz
Revision bump to v0.1-2.
-rw-r--r--.SRCINFO9
-rw-r--r--ChangeLog5
-rw-r--r--PKGBUILD10
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d44cf2cc9d8..d4859313d7ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Sep 18 08:22:58 UTC 2018
pkgbase = nidaqmx-dummy
pkgdesc = Dummy library to compile and link code using NI DAQmx under Linux
pkgver = 0.1
- pkgrel = 1
+ pkgrel = 2
url = http://doesnotexist.sourceforge.net/
changelog = ChangeLog
arch = i686
@@ -14,8 +12,7 @@ pkgbase = nidaqmx-dummy
arch = aarch64
license = GPL3
depends = glibc
- source = http://doesnotexist.sourceforge.net/projects/doesnotexist/files/nidaqmx-dummy-0.1.tar.gz
- sha512sums = f8b29dc52e852035ac6c9c2f38f098f53f78444ddd3b38039ae206a9367198cbe72f95d44b94b86dd0c2fa88f4ad00bf453b050512e62688f629aba1c197a2b3
+ source = NSSDfile://nidaqmx-dummy-0.1.tar.gz
+ sha512sums = SKIP
pkgname = nidaqmx-dummy
-
diff --git a/ChangeLog b/ChangeLog
index 2b5451ef7919..6730acbee9e2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
ChangeLog for nidaqmx-dummy PKGBUILD
+* nidaqmx-dummy-0.0.1-2 (2022-05-05 - AstroFloyd)
+ Make clear in the PKGBUILD how to obtain the source.
+
* nidaqmx-dummy-0.0.1-1 (2018-09-11 - AstroFloyd)
- Initial PKGBUILD for nidaqmx-dummy, to be uploaded to AUR
+ Initial PKGBUILD for nidaqmx-dummy, to be uploaded to AUR.
diff --git a/PKGBUILD b/PKGBUILD
index 785e83e80e42..254377075e56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: AstroFloyd < AstroFloyd [at] gmail >
pkgname=nidaqmx-dummy
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Dummy library to compile and link code using NI DAQmx under Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://doesnotexist.sourceforge.net/"
@@ -9,8 +9,10 @@ license=('GPL3')
depends=('glibc')
makedepends=()
changelog=ChangeLog
-source=("http://doesnotexist.sourceforge.net/projects/doesnotexist/files/$pkgname-$pkgver.tar.gz")
-sha512sums=('f8b29dc52e852035ac6c9c2f38f098f53f78444ddd3b38039ae206a9367198cbe72f95d44b94b86dd0c2fa88f4ad00bf453b050512e62688f629aba1c197a2b3')
+source=("NSSDfile://nidaqmx-dummy-0.1.tar.gz")
+sha512sums=('SKIP')
+
+DLAGENTS+=('NSSDfile::/usr/bin/echo "Please read the Pinned Commment of 2020-06-10 at https://aur.archlinux.org/packages/nidaqmx-dummy and send me an email (https://aur.archlinux.org/account/AstroFloyd) if you want to try this package. I can then send you the tarball and you can put it next to the PKGBUILD to compile and install it.)"')
prepare() {
cp etc/Makefile .
@@ -24,5 +26,5 @@ package() {
mkdir -p ${pkgdir}/usr/include/ ${pkgdir}/usr/lib/
cp -v src/NIDAQmx.h ${pkgdir}/usr/include/
cp -v libNIDAQmx.so ${pkgdir}/usr/lib/
- #cp -v libNIDAQmx.a ${pkgdir}/usr/lib/
+ # cp -v libNIDAQmx.a ${pkgdir}/usr/lib/
}