summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-03-15 16:39:56 +0000
committerMilk Brewster2020-03-15 16:39:56 +0000
commite196c8f4f6c1f5f60aaacbb16555e03f1243d2c8 (patch)
tree9073d9a71300beda991e5e8c0ec21458442d7f54
downloadaur-njl.lv2-git.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..526f8dd1409f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = njl.lv2-git
+ pkgdesc = NJL plugins by Nick Lamb ported to the LV2 specification
+ pkgver = v0.0.3.r2.gb132f0d
+ pkgrel = 1
+ url = https://github.com/linuxmao-org/njl-lv2
+ arch = x86_64
+ groups = lv2plugins
+ license = GPL
+ depends = lv2
+ source = njl.lv2-git::git+https://github.com/linuxmao-org/njl-lv2
+ md5sums = SKIP
+
+pkgname = njl.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..938f61a89a5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+pkgname=njl.lv2-git
+pkgdesc="NJL plugins by Nick Lamb ported to the LV2 specification"
+pkgver=v0.0.3.r2.gb132f0d
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/linuxmao-org/njl-lv2"
+license=(GPL)
+groups=(lv2plugins)
+depends=(lv2)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(njl.lv2-git::git+https://github.com/linuxmao-org/njl-lv2)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ # ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p ${pkgdir}/usr/lib/lv2
+ make INSTALL_DIR="${pkgdir}/usr/lib/lv2" install-system
+}