summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-11-11 01:28:45 +0800
committerYen Chi Hsuan2017-11-11 01:28:45 +0800
commit1c8dec08f01f10ccaa5d9b664b0bd83b39bd306f (patch)
tree805411f1e538f69c68e9d21350ea097df90685be
parent069f4be5a2743eb1580a585288d8792422d65048 (diff)
downloadaur-1c8dec08f01f10ccaa5d9b664b0bd83b39bd306f.tar.gz
Switched to yarn as npm is broken
Ref: https://github.com/npm/npm/issues/19019 https://github.com/nodejs/node/issues/16649 npm team member said "The “real” fix would be waiting for the next npm release." Yet I don't want to wait at all! Seems some of npm's dependencies are not compatible with node 9 https://github.com/npm/npm/commit/c851bb503a756b7cd48d12ef0e12f39e6f30c577 (Bumping node-tar) https://github.com/npm/node-tar/commit/ea90c6cec64044a45448b90bd363c4bf603aff9f (Bumping minipass and minizlib) https://github.com/isaacs/minizlib/commit/a40d6ce1c6465e7488e522a5f8e5373b27d45152 (Update zlib API usage for node 9) And it's rather stranger for a scripting engine that crashes for a known misuse. A JavaScript exception should be thrown instead.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda583a408e3..78d57aac9d15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = nodejs-web-ext
pkgdesc = A command line tool to help build, run, and test web extensions
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://developer.mozilla.org/en-US/Add-ons/WebExtensions
arch = any
license = MPL2
- makedepends = npm
+ makedepends = yarn
depends = nodejs
source = https://registry.npmjs.org/web-ext/-/web-ext-2.2.2.tgz
sha256sums = 802293cb2fce76ff8cd5acb831131efdd73210da062808818fc331a2a94359a1
diff --git a/PKGBUILD b/PKGBUILD
index e24e63819bf4..01b0ab5a4c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_npmname=web-ext
pkgname=nodejs-$_npmname # All lowercase
pkgver=2.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='A command line tool to help build, run, and test web extensions'
arch=(any)
url='https://developer.mozilla.org/en-US/Add-ons/WebExtensions'
license=('MPL2')
depends=('nodejs')
-makedepends=('npm')
+makedepends=('yarn')
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
sha256sums=('802293cb2fce76ff8cd5acb831131efdd73210da062808818fc331a2a94359a1')
@@ -22,7 +22,7 @@ package() {
cp -r --no-preserve=ownership package "$_npmdir/$_npmname"
cd "$_npmdir/$_npmname"
- npm install --production
+ yarn install --production
mkdir -p "$pkgdir/usr/bin"
ln -s "/usr/lib/node_modules/$_npmname/bin/$_npmname" "$pkgdir/usr/bin/$_npmname"