summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-05-24 14:31:09 +0200
committerwereii2021-05-31 16:40:27 +0200
commitd2c9513f94c12518809f8a1cd1dc946076786f09 (patch)
tree91574fe2a2374d924e0587cea25f3b2b622a4062
parent020916a4fe10b906f3f45a1f5fdd5b7c4dfe58a8 (diff)
downloadaur-d2c9513f94c12518809f8a1cd1dc946076786f09.tar.gz
upgpkg: nomachine-enterprise-client 7.6.2-1
upstream release; - now installed into /opt instead of /usr - moved as much unpacking & installation into pkgbuild instead of calling upstream install script
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--client.cfg14
-rw-r--r--nm-ent-client.install34
-rwxr-xr-xnomachine-client3
-rw-r--r--player.cfg14
6 files changed, 86 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79b40f9c734c..2e705ee7c993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = nomachine-enterprise-client
pkgdesc = Remote desktop application
- pkgver = 7.4.1
+ pkgver = 7.6.2
pkgrel = 1
url = http://www.nomachine.com
install = nm-ent-client.install
arch = x86_64
arch = i686
- license = custom:"Copyright 2002-2020 NoMachine S.a r.l."
+ groups = network
+ license = custom:"NoMachine EULA"
conflicts = nomachine
conflicts = nxmanager
conflicts = nxwebplayer
@@ -14,8 +15,18 @@ pkgbase = nomachine-enterprise-client
conflicts = nxnode
conflicts = nxclient
options = !strip
- source = http://download.nomachine.com/download/7.4/Linux/nomachine-enterprise-client_7.4.1_1_x86_64.tar.gz
- sha256sums = ecfc67141c56cdaf8831583c1883254c925b6bdfdfee79065f4c4e6dc4d8254e
+ backup = etc/NX/player/localhost/player.cfg
+ backup = etc/NX/player/localhost/client.cfg
+ source = player.cfg
+ source = client.cfg
+ source = nomachine-client
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ source_x86_64 = http://download.nomachine.com/download/7.6/Linux/nomachine-enterprise-client_7.6.2_4_x86_64.tar.gz
+ sha256sums_x86_64 = 399f1ab3ddcd28519ded95d46f64a222743224cb6aa5cb8af637e2260c3093e0
+ source_i686 = http://download.nomachine.com/download/7.6/Linux/nomachine-enterprise-client_7.6.2_1_i686.tar.gz
+ sha256sums_i686 = db9be126898bf9d2052db12596abf236d05d41698cc9249ae68a645b2d474a88
pkgname = nomachine-enterprise-client
diff --git a/PKGBUILD b/PKGBUILD
index 0fba8096ece5..2faf1e34e5a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,39 @@
-# Maintainer: FD <fxd@seznam.cz>
+# Maintainer: wereii <me+aur at wereii.cz>
+# Contributor: FD <fxd@seznam.cz>
pkgname=nomachine-enterprise-client
-pkgver=7.4.1
+pkgver=7.6.2
+_x64_rel=4
+_i686_rel=1
pkgrel=1
-x64_rel=1
-i386_rel=1
pkgdesc="Remote desktop application"
+groups=('network')
url="http://www.nomachine.com"
-license=('custom:"Copyright 2002-2020 NoMachine S.a r.l."')
+license=('custom:"NoMachine EULA"')
arch=('x86_64' 'i686')
options=('!strip')
conflicts=(nomachine nxmanager nxwebplayer nxserver nxnode nxclient)
install=nm-ent-client.install
+backup=(etc/NX/player/localhost/{player,client}.cfg)
-if [ "${CARCH}" = "x86_64" ]; then
- sha256sums=("ecfc67141c56cdaf8831583c1883254c925b6bdfdfee79065f4c4e6dc4d8254e")
- _carch=_x86_64
- source=("http://download.nomachine.com/download/7.4/Linux/${pkgname}_${pkgver}_${x64_rel}${_carch}.tar.gz")
-elif [ "${CARCH}" = "i686" ]; then
- sha256sums=("ca0ea984ff7c5f969c5a3d695105c1e492df5b10761bb70337f7773fb606b836")
- _carch=_i686
- source=("http://download.nomachine.com/download/7.4/Linux/${pkgname}_${pkgver}_${i386_rel}${_carch}.tar.gz")
-fi
+source=(player.cfg client.cfg nomachine-client)
+sha256sums=(SKIP SKIP SKIP)
+
+source_x86_64=("http://download.nomachine.com/download/${pkgver%*.*}/Linux/${pkgname}_${pkgver}_${_x64_rel}_x86_64.tar.gz")
+source_i686=("http://download.nomachine.com/download/${pkgver%*.*}/Linux/${pkgname}_${pkgver}_${_i686_rel}_i686.tar.gz")
+
+sha256sums_x86_64=('399f1ab3ddcd28519ded95d46f64a222743224cb6aa5cb8af637e2260c3093e0')
+sha256sums_i686=('db9be126898bf9d2052db12596abf236d05d41698cc9249ae68a645b2d474a88')
package()
{
- cd "${srcdir}"
- install -d "${pkgdir}/usr/"
- cp -a NX "${pkgdir}/usr/NX"
-}
+ install -Dm644 player.cfg client.cfg -t "${pkgdir}/etc/NX/player/localhost"
+ install -Dm755 nomachine-client -t "${pkgdir}/usr/bin"
+
+ mkdir -p "${pkgdir}/opt"
+ cd "${pkgdir}/opt"
+ tar -xzf "${srcdir}/NX/etc/NX/player/packages/nxclient.tar.gz"
+ tar -xzf "${srcdir}/NX/etc/NX/player/packages/nxplayer.tar.gz"
+
+}
diff --git a/client.cfg b/client.cfg
new file mode 100644
index 000000000000..9d6b3b124431
--- /dev/null
+++ b/client.cfg
@@ -0,0 +1,14 @@
+######################################################################
+# #
+# Copyright (c) 2002, 2021 NoMachine, http://www.nomachine.com. #
+# #
+# All rights reserved. #
+# #
+######################################################################
+
+#
+# Specify the path of base directory where the NX software has been
+# installed.
+#
+
+ClientRoot = "/opt/NX"
diff --git a/nm-ent-client.install b/nm-ent-client.install
index ec89056a875e..602e8d01ac6b 100644
--- a/nm-ent-client.install
+++ b/nm-ent-client.install
@@ -1,29 +1,25 @@
-post_install()
+_check_remove_old_prefix()
{
- echo "creating file /etc/fedora-release (temporarily)..."
- touch /etc/fedora-release
- echo "Running NX post_install script..."
- /usr/NX/nxclient --install fedora
- echo "deleting file /etc/fedora-release..."
- rm /etc/fedora-release
+ if [ -d /usr/NX ]; then
+ echo "Old installation (/usr) found, removing"
+
+ if [ -x /usr/NX/scripts/setup/nxclient ]; then
+ NX_INSTALL_PREFIX=/usr /usr/NX/scripts/setup/nxclient --uninstall fedora
+ fi
+
+ rm -rf /usr/NX
+ fi
}
pre_remove()
{
echo "Running NX pre_remove script..."
- /usr/NX/scripts/setup/nxclient --uninstall fedora
+ NX_INSTALL_PREFIX=/opt /opt/NX/scripts/setup/nxclient --uninstall arch
+ rm -rf /opt/NX
}
-post_remove()
-{
- echo "Removing /usr/NX..."
- rm -rf /usr/NX
-}
-pre_upgrade() {
- pre_remove
-}
-
-post_upgrade() {
- post_install
+pre_upgrade()
+{
+ _check_remove_old_prefix
}
diff --git a/nomachine-client b/nomachine-client
new file mode 100755
index 000000000000..6650b1349f8f
--- /dev/null
+++ b/nomachine-client
@@ -0,0 +1,3 @@
+#!/usr/bin/env sh
+
+/opt/NX/bin/nxclient --monitor
diff --git a/player.cfg b/player.cfg
new file mode 100644
index 000000000000..74dc3c62d2f6
--- /dev/null
+++ b/player.cfg
@@ -0,0 +1,14 @@
+######################################################################
+# #
+# Copyright (c) 2010, 2021 NoMachine, http://www.nomachine.com. #
+# #
+# All rights reserved. #
+# #
+######################################################################
+
+#
+# Specify the path of base directory where the NX software has been
+# installed.
+#
+
+PlayerRoot = "/opt/NX"