summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Collins2024-03-06 17:03:04 +0000
committerMark Collins2024-03-06 17:03:04 +0000
commit6f7d3f49d316c9a46011a709fec53f4c445df3ad (patch)
tree0c8ba5e4af539a4e0bdcf0c21d4ccd14f759f7df
parent892f6dacaff89cac5fa1c47b681e808cf14dc971 (diff)
downloadaur-noseyparker.tar.gz
v0.17.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801158fa4257..c4e92520b507 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = noseyparker
pkgdesc = find secrets and sensitive information in textual data and Git history
- pkgver = 0.16.0
- pkgrel = 2
+ pkgver = 0.17.0
+ pkgrel = 1
url = https://github.com/praetorian-inc/noseyparker
arch = x86_64
license = Apache-2.0
@@ -11,7 +11,7 @@ pkgbase = noseyparker
depends = gcc-libs
depends = glibc
options = !lto
- source = noseyparker-0.16.0::https://github.com/praetorian-inc/noseyparker/archive/refs/tags/v0.16.0.zip
- sha256sums = 8086426ccfc714084d3e3aa4f5dfaa2cf5add970ba90daa1a49924a7b5456e51
+ source = noseyparker-0.17.0::https://github.com/praetorian-inc/noseyparker/archive/refs/tags/v0.17.0.zip
+ sha256sums = 67d78cd8379217032c396b51e196d6e7fe17c103a9716c7ecc22336b3133d5ae
pkgname = noseyparker
diff --git a/PKGBUILD b/PKGBUILD
index 6f1b1527946d..65820eead891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Collins <tera_1225 [aaht] hotmail ðot com>
pkgname=noseyparker
-pkgver=0.16.0
-pkgrel=2
+pkgver=0.17.0
+pkgrel=1
pkgdesc="find secrets and sensitive information in textual data and Git history"
arch=('x86_64')
url="https://github.com/praetorian-inc/noseyparker"
@@ -16,7 +16,7 @@ makedepends=(
'pkgconfig' # Vectorscan dep
)
source=("${pkgname}-${pkgver}::${url}/archive/refs/tags/v${pkgver}.zip")
-sha256sums=('8086426ccfc714084d3e3aa4f5dfaa2cf5add970ba90daa1a49924a7b5456e51')
+sha256sums=('67d78cd8379217032c396b51e196d6e7fe17c103a9716c7ecc22336b3133d5ae')
options=(!lto) # Vectorscan build fails with LTO
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -39,9 +39,11 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}"
install -Dm0755 "./target/release/${pkgname}-cli" "${pkgdir}/usr/bin/$pkgname"
mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
- "./target/release/${pkgname}-cli" shell-completions --shell bash > "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ "./target/release/${pkgname}-cli" generate shell-completions --shell bash > "$pkgdir/usr/share/bash-completion/completions/$pkgname"
mkdir -p "${pkgdir}/usr/share/fish/completions/"
- "./target/release/${pkgname}-cli" shell-completions --shell fish > "$pkgdir/usr/share/fish/completions/${pkgname}.fish"
+ "./target/release/${pkgname}-cli" generate shell-completions --shell fish > "$pkgdir/usr/share/fish/completions/${pkgname}.fish"
mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
- "./target/release/${pkgname}-cli" shell-completions --shell zsh > "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ "./target/release/${pkgname}-cli" generate shell-completions --shell zsh > "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ mkdir -p "$pkgdir/usr/share/man/man1/"
+ "./target/release/${pkgname}-cli" generate manpages --output "$pkgdir/usr/share/man/man1/"
}