summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark t4802022-12-22 09:25:23 +0100
committerMark t4802022-12-22 09:25:23 +0100
commitaa7bfd6764e7f33e3a283ca853128df955aa9090 (patch)
tree4eb1ced71bd108beecb75b2db0c0dd3a2c68042a
downloadaur-noseyparker-git.tar.gz
Initial commit: created git PKGBUILD for noseyparker
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adeb611d51e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = noseyparker-git
+ pkgdesc = find secrets and sensitive information in textual data and Git history
+ pkgver = r17.9438ab2
+ pkgrel = 1
+ url = https://github.com/praetorian-inc/noseyparker
+ arch = any
+ license = Apache-2
+ makedepends = git
+ makedepends = cargo
+ depends = hyperscan
+ source = noseyparker::git+https://github.com/praetorian-inc/noseyparker.git
+ sha256sums = SKIP
+
+pkgname = noseyparker-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..353dca5c4c9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mark Collins <tera_1225 [aaht] hotmail ðot com>
+pkgname=noseyparker-git
+_pkgname_root="${pkgname%-git}"
+pkgver=r17.9438ab2
+pkgrel=1
+pkgdesc="find secrets and sensitive information in textual data and Git history"
+arch=(any)
+url="https://github.com/praetorian-inc/noseyparker"
+license=('Apache-2')
+makedepends=('git'
+ 'cargo')
+depends=(hyperscan)
+source=("${_pkgname_root}::git+https://github.com/praetorian-inc/${_pkgname_root}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${_pkgname_root}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${_pkgname_root}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$srcdir/${_pkgname_root}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ cd "$srcdir/${_pkgname_root}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$_pkgname_root"
+}