summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHcra2019-06-24 09:17:09 +0200
committerHcra2019-06-24 09:17:09 +0200
commit8b0cb5fe6aed952a3879012941e8467963405135 (patch)
tree8e4d3b843b5774752105bf7d6735ea42ca594fa4
downloadaur-notes-cli-bin.tar.gz
First release.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90ac53815df9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = notes-cli-bin
+ pkgdesc = Small markdown note taking commandline application written in go.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/rhysd/notes-cli
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = notes-cli-1.6.0.zip::https://github.com/rhysd/notes-cli/releases/download/v1.6.0/notes_linux_amd64.zip
+ sha1sums = 17560a53fb3cf3e172c8ae5efd7d624878479023
+
+pkgname = notes-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381ec00262a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: hcra <hcra at u53r dot space>
+
+pkgname=notes-cli-bin
+_pkgname=notes-cli
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Small markdown note taking commandline application written in go."
+arch=('i686' 'x86_64')
+url="https://github.com/rhysd/notes-cli"
+license=('MIT')
+source=("$_pkgname-$pkgver.zip::https://github.com/rhysd/notes-cli/releases/download/v$pkgver/notes_linux_amd64.zip")
+sha1sums=('17560a53fb3cf3e172c8ae5efd7d624878479023')
+
+package() {
+ cd "${srcdir##-bin}"
+
+ install -Dm755 "notes" "$pkgdir/usr/bin/notes"
+ $pkgdir/usr/bin/notes --help-man > notes.1
+ install -Dm644 "notes.1" "$pkgdir/usr/share/man/man1/notes.1"
+}