summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-09-14 09:29:57 +0200
committeraksr2016-09-14 09:29:57 +0200
commit34b207f1c71e011a0e6e95e6bd46e888c25c556c (patch)
tree1e1882a452fc44626faa4ea80bc5cf3ea8504543
downloadaur-notify-cat-git.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08dee8bf69dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Sep 14 07:29:56 UTC 2016
+pkgbase = notify-cat-git
+ pkgdesc = Turn a pipe into notifications
+ pkgver = r7.032e614
+ pkgrel = 1
+ url = https://github.com/psychon/notify-cat
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ conflicts = notify-cat
+ source = notify-cat-git::git+https://github.com/psychon/notify-cat.git
+ md5sums = SKIP
+
+pkgname = notify-cat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85c9295780e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=notify-cat-git
+pkgver=r7.032e614
+pkgrel=1
+epoch=
+pkgdesc="Turn a pipe into notifications"
+arch=('i686' 'x86_64')
+url="https://github.com/psychon/notify-cat"
+license=('WTFPL')
+categories=()
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('notify-cat')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/psychon/notify-cat.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 notify-cat $pkgdir/usr/bin/notify-cat
+ install -Dm644 README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
+}
+