aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe2017-06-07 17:05:11 +0200
committerGiuseppe2017-06-07 17:05:11 +0200
commit3a33eb4148e53ebc19138365b4c8fccaea9f8ced (patch)
tree66de8d3e3e22b45025713c0cc938d3cb8b4db151
parent6ad494f3dfcc9c0c0622c1d9f80ad82a6d84ef74 (diff)
downloadaur-3a33eb4148e53ebc19138365b4c8fccaea9f8ced.tar.gz
Add Makefile to clean the makepkg mess.
-rw-r--r--.SRCINFO5
-rw-r--r--Makefile10
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faf5a7038c16..a335be3fa8c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notify-when-done-i3-git
pkgdesc = Get notifications when commands in non-focused i3's workspaces finish.
- pkgver = r4.9f1752e
- pkgrel = 3
+ pkgver = r19.ee99d96
+ pkgrel = 1
url = https://github.com/giuscri/notify-when-done-i3
install = notify-when-done-i3-git.install
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = notify-when-done-i3-git
depends = jq
depends = i3-wm
depends = bash-preexec-git
+ depends = libnotify
source = notify-when-done-i3-git::git+https://github.com/giuscri/notify-when-done-i3.git
md5sums = SKIP
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..fc30bcf6566c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+# This is actually for hacking around with the script
+# as makepkg -si will leave a mess after exiting.
+
+build:
+ @makepkg -si
+
+clean:
+ @rm -rf pkg/ src/ notify-when-done-i3-git/ *pkg.tar.xz
+
+# vim: set noet ts=4: