aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiuseppe2017-06-08 17:57:21 +0200
committerGiuseppe2017-06-08 17:57:21 +0200
commitcf90f2856d8c6db9c4b13f8ec1c85ea93f1f3dfe (patch)
tree02bcdf28421b56fe1d77b350aa8f10eec42ad8c9
parent631ca29a43c8a743bb1ecacb922158199faf1dce (diff)
downloadaur-cf90f2856d8c6db9c4b13f8ec1c85ea93f1f3dfe.tar.gz
Fix bad path to the tree parser
-rw-r--r--PKGBUILD3
-rw-r--r--preexec.sh4
2 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc110b1ad8ad..ca33ed7c0d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Giuseppe <giuscri@gmail.com>
pkgname='notify-when-done-i3-git'
-pkgver=r25.6b95dd4
+pkgver=r26.631ca29
pkgrel=1
pkgdesc="Get notifications when commands in non-focused i3's window finish."
arch=('x86_64')
@@ -19,5 +19,6 @@ pkgver() {
package() {
install -Dm0644 "$srcdir/$pkgname/preexec.sh" "$pkgdir/usr/share/nwd/preexec.sh"
+ install -Dm0644 "$srcdir/$pkgname/focused_window.py" "$pkgdir/usr/share/nwd/focused_window.py"
install -Dm0644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/nwd/LICENSE"
}
diff --git a/preexec.sh b/preexec.sh
index b2ac0d57f237..a96ef1195dcf 100644
--- a/preexec.sh
+++ b/preexec.sh
@@ -1,7 +1,7 @@
_precmd() {
if [[ -z $NWD_CMD ]]; then return; fi
- CURRENT_FOCUSED_W=$(python3 focused_window.py)
+ CURRENT_FOCUSED_W=$(python3 /usr/share/nwd/focused_window.py)
if [[ $NWD_FOCUSED_W && $CURRENT_FOCUSED_W -ne $NWD_FOCUSED_W ]]; then
notify-send -a nwd "$NWD_CMD"
fi
@@ -12,7 +12,7 @@ _precmd() {
_preexec() {
NWD_CMD=$1
- NWD_FOCUSED_W=$(python3 focused_window.py)
+ NWD_FOCUSED_W=$(python3 /usr/share/nwd/focused_window.py)
}
preexec_functions+=(_preexec)