summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Amundsen2023-04-07 11:08:11 +0200
committerJonas Amundsen2023-04-07 11:09:56 +0200
commitf9b4357140be38a3968bf35e026dbc025b50a5e0 (patch)
treebfcb876d57c22f85bcf43585c713e963973ba2d8
downloadaur-npkill.tar.gz
Initial npkill-0.11.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e713e852146f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = npkill
+ pkgdesc = List any node_modules package dir in your system and how heavy they are. You can then select which ones you want to erase to free up space
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/voidcosmos/npkill
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = npkill-0.11.1.tgz
+ source = http://registry.npmjs.org/npkill/-/npkill-0.11.1.tgz
+ sha1sums = 0cf7a32740c2966aa79392a35742749d6ed2a491
+
+pkgname = npkill
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..532c21522d17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jonas Amundsen <jonasba+aur at gmail dot com>
+
+pkgname=npkill
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="List any node_modules package dir in your system and how heavy they are. You can then select which ones you want to erase to free up space"
+arch=('any')
+url="https://github.com/voidcosmos/npkill"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-${pkgver//_/-}.tgz)
+noextract=($pkgname-${pkgver//_/-}.tgz)
+sha1sums=('dfb2236af6774c8699f1f86e8d3197d3c991b34d')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $pkgname@${pkgver//_/-}
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}