summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrey Blancher2024-04-13 13:45:16 -0400
committerTrey Blancher2024-04-13 13:45:16 -0400
commit3c5b061c939da965deeed0f68e64263f1df50237 (patch)
tree7b37642b2ae54b264b9648907d5c4c03a9f4b153
downloadaur-nrdiag-bin.tar.gz
Initial AUR commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27c1aeded0fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nrdiag-bin
+ pkgdesc = New Relic Diagnostics CLI tool
+ pkgver = 3.2.6
+ pkgrel = 1
+ arch = x86_64
+ arch = aarch64
+ groups = newrelic
+ license = Apache
+ provides = nrdiag
+ conflicts = nrdiag
+ source_x86_64 = https://download.newrelic.com/nrdiag/nrdiag_3.2.6_Linux_x64.tar.gz
+ sha256sums_x86_64 = a3aa9b5c366eaa9dc8e6c8d63c577049d44cd41353c80009488134b139284133
+ source_aarch64 = https://download.newrelic.com/nrdiag/nrdiag_3.2.6_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 4f5f17329ed358c29602c6120de84d7986abb84fdb63407615804853337dd2cf
+
+pkgname = nrdiag-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..580c15e82e48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=nrdiag-bin
+_pkg=nrdiag
+pkgver=3.2.6
+pkgrel=1
+pkgdesc="New Relic Diagnostics CLI tool"
+arch=(x86_64 aarch64)
+url=""
+license=('Apache')
+groups=(newrelic)
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(nrdiag)
+conflicts=(nrdiag)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source_x86_64=("https://download.newrelic.com/${_pkg}/${_pkg}_${pkgver}_Linux_x64.tar.gz")
+source_aarch64=("https://download.newrelic.com/${_pkg}/${_pkg}_${pkgver}_Linux_arm64.tar.gz")
+
+build () {
+ mv ${srcdir}/nrdiag{_x64,}
+}
+
+package() {
+ install -Dm u=rwx,go=rx -o root -g root -t ${pkgdir}/usr/bin ${srcdir}/nrdiag
+}
+sha256sums_x86_64=('a3aa9b5c366eaa9dc8e6c8d63c577049d44cd41353c80009488134b139284133')
+sha256sums_aarch64=('4f5f17329ed358c29602c6120de84d7986abb84fdb63407615804853337dd2cf')