summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Duffy2016-03-12 23:05:20 -0600
committerCharles Duffy2016-03-12 23:07:25 -0600
commitc4d295cd102edb4b6ecef4cb1a9a9a38000ba974 (patch)
treef9b2294ffd948f622b1c2690c1666c0852d3ff27
downloadaur-ns-exec-tools-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4ac8c94bb31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.0
+# Sun Mar 13 05:07:10 UTC 2016
+pkgbase = ns-exec-tools-git
+ pkgdesc = Lightweight, execline-style tools to build restricted Linux namespaces
+ pkgver = r6.447b31a
+ pkgrel = 1
+ url = https://github.com/charles-dyfis-net/ns-exec-tools
+ arch = any
+ license = ISC
+ depends = lxc
+ depends = util-linux
+ conflicts = ns-exec-tools
+ source = ns-exec-tools::git+https://github.com/charles-dyfis-net/ns-exec-tools
+ sha1sums = SKIP
+
+pkgname = ns-exec-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b467daa3dd3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Charles Duffy <charles@dyfis.net>
+pkgname=ns-exec-tools-git
+pkgver=r6.447b31a
+pkgrel=1
+pkgdesc="Lightweight, execline-style tools to build restricted Linux namespaces"
+arch=( any )
+url="https://github.com/charles-dyfis-net/ns-exec-tools"
+license=( ISC )
+depends=( lxc util-linux )
+conflicts=( "${pkgname%-git}" )
+source=( 'ns-exec-tools::git+https://github.com/charles-dyfis-net/ns-exec-tools' )
+sha1sums=( SKIP )
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() { :; }
+
+package() {
+ cd "${pkgname%-git}"
+ mkdir -p \
+ "$pkgdir/usr/share/doc/$pkgname" \
+ "$pkgdir/usr/share/licenses/$pkgname" \
+ "$pkgdir/usr/bin"
+ cp README.md "$pkgdir/usr/share/doc/$pkgname/"
+ cp LICENSE "$pkgdir/usr/share/licenses/$pkgname/"
+ cp [[:lower:]]* "$pkgdir/usr/bin/"
+}