summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2015-07-05 13:09:17 +0300
committerAlexey D2015-07-05 13:10:44 +0300
commit025cf8614b98346adf530979e14f73e4067291b2 (patch)
treedbcce3db0941e8afac704f19524dedcea617fea4
downloadaur-nss-myhostname-separate.tar.gz
version 0.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d304a2fc51c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nss-myhostname-separate
+ pkgdesc = NSS plugin providing host name resolution for the locally configured system hostname
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://0pointer.de/lennart/projects/nss-myhostname/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = glibc
+ provides = nss-myhostname=0.3
+ conflicts = nss-myhostname
+ replaces = nss-myhostname
+ source = http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-0.3.tar.gz
+ md5sums = d4ab9ac36c053ab8fb836db1cbd4a48f
+
+pkgname = nss-myhostname-separate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e69d987d27fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Mantas M. <grawity@gmail.com>
+pkgname="nss-myhostname-separate"
+_realname="nss-myhostname"
+pkgver=0.3
+pkgrel=1
+pkgdesc="NSS plugin providing host name resolution for the locally configured system hostname"
+arch=(i686 x86_64)
+url="http://0pointer.de/lennart/projects/nss-myhostname/"
+license=('LGPL2.1')
+depends=('glibc')
+provides=("nss-myhostname=${pkgver}")
+conflicts=('nss-myhostname')
+replaces=('nss-myhostname')
+source=("http://0pointer.de/lennart/projects/${_realname}/${_realname}-${pkgver}.tar.gz")
+md5sums=('d4ab9ac36c053ab8fb836db1cbd4a48f')
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-lynx
+ make
+}
+
+package() {
+ cd "$srcdir/${_realname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+