summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohnnybash2024-02-09 20:34:47 +0100
committerjohnnybash2024-02-09 20:34:47 +0100
commita0d7c489d3deb783a27364e36ea270dac1741f3e (patch)
tree3e54a50996e57d18da990f8849de4cd51cc5553d
parent4c8381e4203fcbaa75e9e0f3745b350f2204cb6a (diff)
downloadaur-a0d7c489d3deb783a27364e36ea270dac1741f3e.tar.gz
upgpkg: ntopng 6.0-2
fix compiling css
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a791bcf817e..14436018dbbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ntopng
pkgdesc = The next generation version of the original ntop, a network traffic probe that shows the network usage
pkgver = 6.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.ntop.org/
install = ntopng.install
arch = x86_64
arch = i686
- license = GPL3
+ license = GPL-3.0-only
makedepends = glib2
makedepends = automake
makedepends = libtool
@@ -14,6 +14,7 @@ pkgbase = ntopng
makedepends = curl
makedepends = libxml2
makedepends = npm
+ makedepends = jq
depends = redis
depends = libmariadbclient
depends = libpcap
@@ -22,6 +23,8 @@ pkgbase = ntopng
depends = zeromq
depends = rrdtool
depends = hiredis
+ depends = curl
+ depends = json-c
source = ntopng-6.0.tar.gz::https://github.com/ntop/ntopng/archive/6.0.tar.gz
source = nDPI-4.8.tar.gz::https://github.com/ntop/nDPI/archive/4.8.tar.gz
source = ntopng@.service
diff --git a/PKGBUILD b/PKGBUILD
index 8cf0d689b27d..ed91d13b160a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ validpgpkeys=('EFD9413B17293AFDFE6EA6F1402A088DEDF104CB')
pkgname=ntopng
pkgver=6.0
_ndpiver=4.8
-pkgrel=1
+pkgrel=2
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686')
url='http://www.ntop.org/'
-license=('GPL3')
-depends=('redis' 'libmariadbclient' 'libpcap' 'sqlite' 'libmaxminddb' 'zeromq' 'rrdtool' 'hiredis')
-makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2' 'npm')
+license=('GPL-3.0-only')
+depends=('redis' 'libmariadbclient' 'libpcap' 'sqlite' 'libmaxminddb' 'zeromq' 'rrdtool' 'hiredis' 'curl' 'json-c')
+makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2' 'npm' 'jq')
install=$pkgname.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/ntop/$pkgname/archive/$pkgver.tar.gz"
"nDPI-$_ndpiver.tar.gz::https://github.com/ntop/nDPI/archive/$_ndpiver.tar.gz"
@@ -37,8 +37,9 @@ build() {
cd $srcdir/$pkgname-$pkgver
./autogen.sh
./configure --prefix=$pkgdir/usr --datadir=/usr/share
- npm install
- npm run build
+ npm install --save-dev @babel/core
+ jq -c '.devDependencies' package.json | jq -r -M | grep ':' | sed 's/:/@/' | sed 's|[", ^]||g' | npm install --save-dev
+ npm run build:dev
make
}