summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Poulin2015-08-08 19:51:13 -0400
committerMaxime Poulin2015-08-08 19:51:13 -0400
commitadbbc3ba3e497f8fd71add8bcf086b2f6b2c7e88 (patch)
tree7f9a88476a47ab3f366bb8419d60da9d7bd2047d
downloadaur-numix-shine-icon-theme-git.tar.gz
Port package from AUR3 to AUR4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--numix-shine-icon-theme.install13
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9aeb6a8836bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = numix-shine-icon-theme-git
+ pkgdesc = An icon theme from the Numix project with a glossy design
+ pkgver = 5.428f9a8
+ pkgrel = 2
+ url = https://github.com/numixproject/numix-icon-theme-shine
+ install = numix-shine-icon-theme.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = numix-icon-theme-git
+ provides = numix-shine-icon-theme
+ conflicts = numix-shine-icon-theme
+ source = git://github.com/numixproject/numix-icon-theme-shine.git
+ md5sums = SKIP
+
+pkgname = numix-shine-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67f7ee47155e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: naxuroqa <naxuroqa@gmail.com>
+
+pkgname=numix-shine-icon-theme-git
+_gitname=numix-icon-theme-shine
+pkgver=5.428f9a8
+pkgrel=2
+pkgdesc="An icon theme from the Numix project with a glossy design"
+arch=('any')
+url="https://github.com/numixproject/numix-icon-theme-shine"
+license=('GPL3')
+depends=('numix-icon-theme-git')
+makedepends=('git')
+optdepends=()
+provides=('numix-shine-icon-theme')
+conflicts=('numix-shine-icon-theme')
+install="numix-shine-icon-theme.install"
+source=('git://github.com/numixproject/numix-icon-theme-shine.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd $_gitname
+
+ install -d -m 755 "$pkgdir"/usr/share/icons
+ cp -dr --no-preserve=ownership Numix-Shine "$pkgdir"/usr/share/icons/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/numix-shine-icon-theme.install b/numix-shine-icon-theme.install
new file mode 100644
index 000000000000..5cc78308029c
--- /dev/null
+++ b/numix-shine-icon-theme.install
@@ -0,0 +1,13 @@
+post-install() {
+ gtk-update-icon-cache -ftq usr/share/icons/Numix-Shine
+}
+
+post-upgrade() {
+ post-install
+}
+
+post-remove() {
+ post-install
+}
+
+# vim: ts=2 sw=2 et: