summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhoppi Chaw2015-06-09 12:18:21 +0800
committerBhoppi Chaw2015-06-09 12:18:21 +0800
commita9f49f0f843dadab21a937a99e954b67b6b326ff (patch)
tree9ba00aa4326307637b36a33ac73f63b6e006b8b0
downloadaur-a9f49f0f843dadab21a937a99e954b67b6b326ff.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
-rw-r--r--license2
-rw-r--r--nutstore.install21
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89c63a996e86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Thu May 28 08:11:49 UTC 2015
+pkgbase = nutstore
+ pkgdesc = a cloud service that lets you sync and share files anywhere.
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = https://jianguoyun.com/
+ install = nutstore.install
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = gtk2
+ depends = java-runtime
+ depends = python2-notify
+ optdepends = nautilus-nutstore: Nautilus plugin
+ source = license
+ md5sums = 3d2b5207cb2f8faeb22625976953151d
+ source_x86_64 = https://jianguoyun.com/static/exe/st/3.3.2/nutstore_client-3.3.2-linux-x64.tar.gz
+ md5sums_x86_64 = 36dd79961502afaef2d5d82f7909400e
+ source_i686 = https://jianguoyun.com/static/exe/st/3.3.2/nutstore_client-3.3.2-linux-x86.tar.gz
+ md5sums_i686 = f9a180369f6ceef58cf4f2cc20355ad4
+
+pkgname = nutstore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae10f1163cd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+#Maintainer: Bhoppi Chaw <bhoppi#outlook,com>
+
+pkgname=nutstore
+pkgver=3.3.2
+pkgrel=1
+pkgdesc='a cloud service that lets you sync and share files anywhere.'
+arch=(x86_64 i686)
+url='https://jianguoyun.com/'
+license=(custom)
+depends=(gtk2
+ java-runtime
+ python2-notify)
+optdepends=('nautilus-nutstore: Nautilus plugin')
+install='nutstore.install'
+source=(license)
+source_x86_64=("https://jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x64.tar.gz")
+source_i686=("https://jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x86.tar.gz")
+md5sums=(3d2b5207cb2f8faeb22625976953151d)
+md5sums_x86_64=(36dd79961502afaef2d5d82f7909400e)
+md5sums_i686=(f9a180369f6ceef58cf4f2cc20355ad4)
+
+build()
+{
+ cd $srcdir
+ sed -i -e '1s/python/python2/' bin/nutstore-pydaemon.py
+ cd gnome-config
+ sed -i -e '/Exec=/s,~/\.nutstore/dist,/opt/nutstore,'\
+ menu/nutstore-menu.desktop autostart/nutstore-daemon.desktop
+}
+
+package()
+{
+ cd $srcdir
+ install -D -m 644 license $pkgdir/usr/share/licenses/$pkgname/license
+ rm license *.tar.gz
+ mkdir -p $pkgdir/opt/$pkgname && cp -aR ./ $pkgdir/opt/$pkgname
+ install -D -m 644 gnome-config/menu/nutstore-menu.desktop\
+ $pkgdir/usr/share/applications/nutstore-menu.desktop
+ install -D -m 644 app-icon/nutstore.png\
+ $pkgdir/usr/share/icons/hicolor/64x64/apps/nutstore.png
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..2c94819d57bd
--- /dev/null
+++ b/license
@@ -0,0 +1,2 @@
+license please refer to:
+http://help.jianguoyun.com/?page_id=632
diff --git a/nutstore.install b/nutstore.install
new file mode 100644
index 000000000000..5f155fb39894
--- /dev/null
+++ b/nutstore.install
@@ -0,0 +1,21 @@
+post_install()
+{
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ cat <<EOF
+
+==> To make the option "Auto Start Nutstore" in Preferences work, type below command manually in a terminal after installation.
+$ install -D /opt/nutstore/gnome-config/autostart/nutstore-daemon.desktop ~/.nutstore/dist/gnome-config/autostart/nutstore-daemon.desktop
+
+EOF
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}