summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhoppi Chaw2020-08-07 17:03:13 +0800
committerBhoppi Chaw2020-08-07 17:03:13 +0800
commitf1f22adb5270ba25b36420fff1bb92a5327aa766 (patch)
treeee21128ecde1fe8aabf58ce191cf0a7d132b4f5b
parent0481e865bc7d3f586b47229f47c20136585fa3ff (diff)
downloadaur-f1f22adb5270ba25b36420fff1bb92a5327aa766.tar.gz
update to 5.0.1(ex)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rwxr-xr-xnutstore2
-rw-r--r--nutstore-pydaemon.py-4.1.5.patch15
4 files changed, 14 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76538ca95ba7..17f3269389c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nutstore
pkgdesc = a cloud service that lets you sync and share files anywhere.
- pkgver = 4.1.5
- pkgrel = 2
+ pkgver = 5.0.1
+ pkgrel = 1
url = https://www.jianguoyun.com/
arch = x86_64
license = custom
@@ -11,12 +11,10 @@ pkgbase = nutstore
optdepends = nautilus-nutstore: Nautilus plugin
source = nutstore
source = license
- source = nutstore-pydaemon.py-4.1.5.patch
- sha256sums = 3091740b20ddd31ba4407b8daba1077c4677040cdc47bccfab2f7f3947676384
+ sha256sums = a4aa358d45b306cbeac449f2256f00a5b81a95197394eba7efa96eaae820cf5b
sha256sums = f3d2861ff48f2d193a4eced23a02b4eba9fab4c1d3f727e934ed7c59f38f0f7e
- sha256sums = 19d680f53f56931609a0943aa6356696419d62297ae57da263363c4a875d2312
- source_x86_64 = https://www.jianguoyun.com/static/exe/st/4.1.5/nutstore_client-4.1.5-linux-x64-public.tar.gz
- sha256sums_x86_64 = 9d41854c2d654085c2004b5da738c3ba9152d5de8c15a9fb9d1df8efd2e021a3
+ source_x86_64 = https://www.jianguoyun.com/static/exe/ex/5.0.1/nutstore_client-5.0.1-linux-x64-public.tar.gz
+ sha256sums_x86_64 = e4774d958bdeb626a5ab8d05dac32b392d6dc17148c7bef2037f80f404baf88d
pkgname = nutstore
diff --git a/PKGBUILD b/PKGBUILD
index f213baaa1550..b51530507a70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,21 @@
#Maintainer: Bhoppi Chaw <bhoppi#outlook,com>
pkgname=nutstore
-pkgver=4.1.5
-pkgrel=2
+pkgver=5.0.1
+pkgrel=1
pkgdesc='a cloud service that lets you sync and share files anywhere.'
arch=(x86_64)
url='https://www.jianguoyun.com/'
license=(custom)
depends=(libappindicator-gtk3 libnotify python-gobject)
optdepends=('nautilus-nutstore: Nautilus plugin')
-source=(nutstore license nutstore-pydaemon.py-4.1.5.patch)
-source_x86_64=("https://www.jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x64-public.tar.gz")
-#source_i686=("https://www.jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x86-public.tar.gz")
-sha256sums=('3091740b20ddd31ba4407b8daba1077c4677040cdc47bccfab2f7f3947676384'
- 'f3d2861ff48f2d193a4eced23a02b4eba9fab4c1d3f727e934ed7c59f38f0f7e'
- '19d680f53f56931609a0943aa6356696419d62297ae57da263363c4a875d2312')
-sha256sums_x86_64=('9d41854c2d654085c2004b5da738c3ba9152d5de8c15a9fb9d1df8efd2e021a3')
+source=(nutstore license)
+source_x86_64=("https://www.jianguoyun.com/static/exe/ex/$pkgver/nutstore_client-$pkgver-linux-x64-public.tar.gz")
+sha256sums=('a4aa358d45b306cbeac449f2256f00a5b81a95197394eba7efa96eaae820cf5b'
+ 'f3d2861ff48f2d193a4eced23a02b4eba9fab4c1d3f727e934ed7c59f38f0f7e')
+sha256sums_x86_64=('e4774d958bdeb626a5ab8d05dac32b392d6dc17148c7bef2037f80f404baf88d')
build() {
- cd $srcdir
- patch bin/nutstore-pydaemon.py nutstore-pydaemon.py-4.1.5.patch
cd $srcdir/gnome-config
sed -i '/Exec=/s|~/\.nutstore/dist/bin/nutstore-pydaemon.py|/usr/bin/nutstore|' menu/nutstore-menu.desktop
sed -i '/Exec=/s|~/\.nutstore/dist|/opt/nutstore|' autostart/nutstore-daemon.desktop
@@ -31,7 +27,7 @@ package() {
cd $srcdir
install -D -m755 nutstore $pkgdir/usr/bin/nutstore
install -D -m644 license $pkgdir/usr/share/licenses/$pkgname/license
- rm nutstore license *.patch *.tar.gz
+ rm nutstore license *.tar.gz
mkdir -p $pkgdir/opt/$pkgname && cp -aR ./ $pkgdir/opt/$pkgname
install -D -m644 gnome-config/menu/nutstore-menu.desktop $pkgdir/usr/share/applications/nutstore.desktop
install -D -m644 app-icon/nutstore.png $pkgdir/usr/share/icons/hicolor/64x64/apps/nutstore.png
diff --git a/nutstore b/nutstore
index a48798abbd62..3994d5abb8f8 100755
--- a/nutstore
+++ b/nutstore
@@ -1,4 +1,4 @@
#!/usr/bin/env sh
STARTPATH='gnome-config/autostart/nutstore-daemon.desktop'
install -CD /opt/nutstore/$STARTPATH ~/.nutstore/dist/$STARTPATH
-/opt/nutstore/bin/nutstore-pydaemon.py
+exec /opt/nutstore/bin/nutstore-pydaemon.py
diff --git a/nutstore-pydaemon.py-4.1.5.patch b/nutstore-pydaemon.py-4.1.5.patch
deleted file mode 100644
index 3dd76de6507e..000000000000
--- a/nutstore-pydaemon.py-4.1.5.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-@@ -32,3 +32,3 @@
- def get_nutstore_dir():
-- dist = get_dist_dir()
-+ dist = os.getenv('HOME') + '/.nutstore/dist'
- if os.path.basename(dist) != "dist":
-@@ -42,3 +42,3 @@
- if not os.path.exists(LOGDIR):
-- os.mkdir(LOGDIR)
-+ os.makedirs(LOGDIR, exist_ok=True)
- # Don't try config logging with config file
-@@ -54,4 +54,2 @@
- logging.basicConfig(
-- filename=LOGFILE,
-- filemode='a',
- datefmt="%m/%d/%Y %H:%M:%S",