summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-02-21 09:30:23 +0100
committerJulien Nicoulaud2019-02-21 09:30:23 +0100
commitb5aaa73d25af60edaab55830e0be2ebd62d9b3f3 (patch)
tree5f6a1fc4db49c42afca40e437faa45c6a9fadc30
downloadaur-nutty.tar.gz
1.1.1
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
-rw-r--r--nutty.install16
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbbbbe4bb135
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = nutty
+ pkgdesc = A network utility for linux. Monitor the devices on your network and check bandwidth and speed details.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/babluboy/nutty
+ install = nutty.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = meson
+ depends = gtk3
+ depends = granite
+ depends = sqlite
+ depends = libxml2
+ depends = libnotify
+ depends = libgee
+ depends = net-tools
+ depends = nethogs
+ depends = nmap
+ depends = traceroute
+ depends = vnstat
+ depends = curl
+ depends = wireless_tools
+ depends = iproute2
+ depends = pciutils
+ provides = nutty
+ conflicts = nutty-git
+ source = https://github.com/babluboy/nutty/archive/1.1.1.tar.gz
+ sha256sums = b6c9ef1966d1c60480943313f20cd66ee1b5d23ac8d6578f457fb99f0898d9ba
+
+pkgname = nutty
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eab14e54627
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
+/*.zst
+/*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07cceb2da58e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+pkgname=nutty
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A network utility for linux. Monitor the devices on your network and check bandwidth and speed details.'
+arch=('i686' 'x86_64')
+url='https://github.com/babluboy/nutty'
+license=('GPL3')
+depends=('gtk3' 'granite' 'sqlite' 'libxml2' 'libnotify' 'libgee' 'net-tools' 'nethogs' 'nmap' 'traceroute' 'vnstat' 'curl' 'wireless_tools' 'iproute2' 'pciutils')
+makedepends=('vala' 'meson')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+install="${pkgname}.install"
+source=("https://github.com/babluboy/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('b6c9ef1966d1c60480943313f20cd66ee1b5d23ac8d6578f457fb99f0898d9ba')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}
+
+
+build() {
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ arch-meson
+ ninja
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ DESTDIR=${pkgdir} ninja install
+}
+
diff --git a/nutty.install b/nutty.install
new file mode 100644
index 000000000000..826f632e9bfa
--- /dev/null
+++ b/nutty.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file