summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-02-18 15:13:42 +0800
committertaotieren2022-02-18 15:13:42 +0800
commit91416cb184ab6fabf84ed1ae56fcc9d728f34852 (patch)
treeb235506b339577e5b7c70e1590866aa6e69d9426
downloadaur-nuwriter-git.tar.gz
Add nuwriter-git
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD47
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e16379eab0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nuwriter-git
+ pkgdesc = The Nu-writer Command Tool is a linux console application consisting of functions to access storage(eg. DRAM,NAND,SPINOR,SPINAND,SD) in a NUC980 family processors
+ pkgver = b7ef934
+ pkgrel = 1
+ url = https://gitee.com/OpenNuvoton/NUC980_NuWriter_CMD
+ arch = any
+ license = GPL3
+ makedepends = gcc
+ makedepends = git
+ makedepends = automake
+ makedepends = pkgconfig
+ depends = libusb
+ provides = NUC980_NuWriter_CMD
+ conflicts = nuwriter
+ options = !strip
+ source = nuwriter::git+https://gitee.com/OpenNuvoton/NUC980_NuWriter_CMD.git
+ sha256sums = SKIP
+
+pkgname = nuwriter-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b1dd7758c9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=nuwriter-git
+pkgver=b7ef934
+pkgrel=1
+epoch=
+pkgdesc="The Nu-writer Command Tool is a linux console application consisting of functions to access storage(eg. DRAM,NAND,SPINOR,SPINAND,SD) in a NUC980 family processors"
+arch=('any')
+url="https://gitee.com/OpenNuvoton/NUC980_NuWriter_CMD"
+license=('GPL3')
+groups=()
+depends=('libusb')
+makedepends=("gcc" "git" "automake" "pkgconfig")
+checkdepends=()
+optdepends=()
+provides=('NUC980_NuWriter_CMD')
+conflicts=(${pkgname%-git})
+replaces=()
+backup=()
+options=('!strip')
+install=
+changelog=
+source=("${pkgname%-git}::git+${url}.git")
+noextract=()
+sha256sums=('SKIP')
+#validpgpkeys=()
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}/"
+# git describe --long --tags | sed 's/V//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ autoreconf -f -i
+# ./configure --prefix=$PWD/install
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+# make install
+ install -Dm0755 ${pkgname%-git} "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm0755 run.ini "${pkgdir}/usr/share/nudata/run.ini"
+ cp -rv nudata "${pkgdir}/usr/share/"
+}