summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhangjinqiang2021-01-17 02:03:00 +0000
committerzhangjinqiang2021-01-17 10:03:00 +0800
commit89241b0faf6d85eb1b19c0e659d523f8908411b2 (patch)
treee303a7de0fbcf9b0cfd3dc9fc3707db6e5bd11bd
parentdcb56f41f815cd073085fba82587c9466db153f7 (diff)
downloadaur-nvchecker-1.7.tar.gz
add provides/conflict, remove check
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f301d56460ac..50b24a4113dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = nvchecker
+pkgbase = nvchecker-1.7
pkgdesc = New version checker for software releases
pkgver = 1.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lilydjwg/nvchecker
arch = any
license = MIT
@@ -21,8 +21,10 @@ pkgbase = nvchecker
optdepends = git: for VCS sources
optdepends = mercurial: for VCS sources
optdepends = subversion: for VCS sources
- source = nvchecker-1.7.tar.gz::https://github.com/lilydjwg/nvchecker/archive/v1.7/nvchecker-1.7.tar.gz
+ provides = nvchecker
+ conflicts = nvchecker
+ source = https://github.com/lilydjwg/nvchecker/archive/v1.7.tar.gz
sha512sums = 6243960747de33bd004bb3377109699f702bb64d65320e0c219f540546f33ace2d87be4eb2b18d988874eb98812176488fa5c98aec6f93cd218b8549b38482d0
-pkgname = nvchecker
+pkgname = nvchecker-1.7
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index da1953a35532..e375028b6101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
-pkgname=nvchecker
+pkgname=nvchecker-1.7
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc="New version checker for software releases"
arch=('any')
url="https://github.com/lilydjwg/nvchecker"
license=('MIT')
+provides=('nvchecker')
+conflicts=('nvchecker')
depends=('python' 'python-setuptools' 'python-structlog' 'python-tornado' 'python-pycurl')
checkdepends=('python-pytest' 'python-pytest-asyncio' 'python-pytest-httpbin' 'python-flaky' 'git' 'mercurial')
optdepends=(
@@ -17,7 +20,7 @@ optdepends=(
'mercurial: for VCS sources'
'subversion: for VCS sources'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/lilydjwg/nvchecker/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+source=("https://github.com/lilydjwg/nvchecker/archive/v$pkgver.tar.gz")
sha512sums=('6243960747de33bd004bb3377109699f702bb64d65320e0c219f540546f33ace2d87be4eb2b18d988874eb98812176488fa5c98aec6f93cd218b8549b38482d0')
build() {
@@ -25,11 +28,6 @@ build() {
python setup.py build
}
-check() {
- cd nvchecker-$pkgver
- pytest
-}
-
package() {
cd nvchecker-$pkgver
# use PYTHONHASHSEED=0 work around https://bugs.python.org/issue34722