summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-12-20 21:07:35 +0000
committerJonathon Fernyhough2020-12-20 21:07:35 +0000
commit84f7fe6ffcb4698cf7dd8abd2dcc01ea483e1c06 (patch)
tree201b31ad172fb78c917c1d656630e9f28ae8a0ff
parentb7c16bc13a2444723661282ae2e083b63d2906c8 (diff)
downloadaur-84f7fe6ffcb4698cf7dd8abd2dcc01ea483e1c06.tar.gz
Add xtrymind/BlackIkeEagle patch for kernel 5.10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb04a35bfc02..fa80e1575abf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-390xx
pkgdesc = NVIDIA drivers for linux, 390xx legacy branch
pkgver = 390.138
- pkgrel = 7
+ pkgrel = 8
url = https://www.nvidia.com/
arch = x86_64
license = custom
@@ -14,10 +14,12 @@ pkgbase = nvidia-390xx
source = kernel-4.16.patch
source = kernel-5.8.patch
source = kernel-5.9.patch
+ source = https://gitlab.com/herecura/packages/nvidia-390xx-dkms/-/blob/db83ed8ac2e0e0097d535a82e2fd4ee0f31873e3/kernel-5.10.patch
b2sums = bf56cef38d76accdf547b96cd444b0bd4288f604d44a1d274f3246c13310d6a59050b36f384280edb83938db81fa0544f7a2dc84ff6f440ff90b76ee62749fc1
b2sums = 1d21307640a3844752c92e8344518daf6ad62d846689bebe6eed4dcadbf7b2e742862f5c17c0faee7256662cb75e62e124d59e5a5617e87324e1f0658f2b748d
b2sums = 1e6ad252be5f603e022c854d391d4d768fb81d532a837203ab3b024dbb10f328c40a9579a19ab730de4e16f3841f15bfbcd1815ec913ac3d555811daf338ae6d
b2sums = 7358919041a3d5df1cac50f6519b282abe7a344f07b59d52ab95a022ce0af12e743a1c194fd838b5733f3900e68c7f0756a528ac32255775f2ba830a2f052dec
+ b2sums = 8d7c054ff08ed6212aa81f3db6597c1e016609bdddfb19161274e5e75b0ae8b5c5501740ca6a75367d152b16f8350319bd2577561aa796cfe49840c4bd2c2d5d
pkgname = nvidia-390xx
pkgdesc = NVIDIA drivers for linux, 390xx legacy branch
diff --git a/PKGBUILD b/PKGBUILD
index 2a9ec86528f0..47c556c6973e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,13 @@
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: loqs
+# Contributor: Dede Dindin Qudsy <xtrymind+gmail+com>
+# Contributor: Ike Devolder <ike.devolder+gmail+com>
pkgbase=nvidia-390xx
pkgname=(nvidia-390xx nvidia-390xx-dkms)
pkgver=390.138
-pkgrel=7
+pkgrel=8
pkgdesc="NVIDIA drivers for linux, 390xx legacy branch"
arch=('x86_64')
url="https://www.nvidia.com/"
@@ -19,11 +21,13 @@ _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
source=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/${_pkg}.run"
'kernel-4.16.patch'
'kernel-5.8.patch'
- 'kernel-5.9.patch')
+ 'kernel-5.9.patch'
+ 'https://gitlab.com/herecura/packages/nvidia-390xx-dkms/-/blob/db83ed8ac2e0e0097d535a82e2fd4ee0f31873e3/kernel-5.10.patch')
b2sums=('bf56cef38d76accdf547b96cd444b0bd4288f604d44a1d274f3246c13310d6a59050b36f384280edb83938db81fa0544f7a2dc84ff6f440ff90b76ee62749fc1'
'1d21307640a3844752c92e8344518daf6ad62d846689bebe6eed4dcadbf7b2e742862f5c17c0faee7256662cb75e62e124d59e5a5617e87324e1f0658f2b748d'
'1e6ad252be5f603e022c854d391d4d768fb81d532a837203ab3b024dbb10f328c40a9579a19ab730de4e16f3841f15bfbcd1815ec913ac3d555811daf338ae6d'
- '7358919041a3d5df1cac50f6519b282abe7a344f07b59d52ab95a022ce0af12e743a1c194fd838b5733f3900e68c7f0756a528ac32255775f2ba830a2f052dec')
+ '7358919041a3d5df1cac50f6519b282abe7a344f07b59d52ab95a022ce0af12e743a1c194fd838b5733f3900e68c7f0756a528ac32255775f2ba830a2f052dec'
+ '8d7c054ff08ed6212aa81f3db6597c1e016609bdddfb19161274e5e75b0ae8b5c5501740ca6a75367d152b16f8350319bd2577561aa796cfe49840c4bd2c2d5d')
prepare() {
sh "${_pkg}.run" --extract-only
@@ -36,21 +40,11 @@ prepare() {
# 5.8 Patch
patch -Np1 -i ../kernel-5.8.patch
- # 5.9 Patch
+ # 5.9 Patch, from loqs
patch -Np1 -i ../kernel-5.9.patch
- ## OLD PATCHES [390.132] ##
-
- # Patch to avoid screen tearing on Optimus Systems [Geeko]
- # patch -Np1 -i ../kernel-5.5.patch
-
- # Patch to make it compile under linux 5.6
- # patch -Np1 -i ../kernel-5.6.patch
-
- # Patch to make it compile under linux 5.7 - Courtesy of openglfreak
- # patch -Np1 -i ../kernel-5.7.patch
-
- ###########################
+ # 5.10 Patch, from xtrymind and BlackIkeEagle
+ patch -Np1 -i ../kernel-5.10.patch
cp -a kernel kernel-dkms
cd kernel-dkms